This is the combination, continued and completion of bandwidth management methods previously using parent queue tree about to handle all sorts of purposes in an internet network that is more complex. Perhaps if you do not want to think too hard, you simply apply the simple queue to limit bandwidth that so powerful and assertive to limit bandwidth per client on your internet network. The problem is if we share the bandwidth with a simple queue is stiffness, and it's hard for me to divide into many clients normally. It would be appropriate to be applied to the kind of dedicated internet connection.
For example If I have a totally the bandwidth internet connection is up to 2M, after i have tested by speed test, the bandwidth average is 512 kbps. It means that if I have 6 clients, be 512/6 = 86 kbps/clients normally, the ideal number is very small inappropriate for our client. If the bandwidth of up to 2 M calculated with 2000/6 to be around 334 kbps /clients, it can makes browsing and online game stuck if just only one client there who download and play streaming video, because the client spend almost all the average speed (512kbps) other clients will be especially problematic just for browsing or online game. In this case we need the priority to the fourth packets.
Full Bandwidth Management with the parent queue tree complete the lack of packets connection per client, especially to handle the internet network with many clients. The principle is equally divide the bandwidth to all the clients with bandwidth greater than that should be given as the limit bandwidth on each clients, in which we set Online Games, Browsing, Download, Video Streaming packets, connection packets. Well, for now I will make the Full Bandwidth Management using the parent queue tree. For more easily to make the complex rule, I will work with the scripts for more quickly.
We will focus on All-Outconn as you can see as the above scripts, the connection packets using chain=forward and out-interface=wlan1. From this marking we get All-Outpkt that we can separate again to the various kind of connection packets that we need.
The mangle scripts above included with the queue tree rules. From here we have just made the download connections packets per clients, such as
Part I : Creating the connection packets per client of download and setup the priority in queue tree rules as you wish, you can see the scripts below!
Here we have used the connections packet per client and to make the download file extension connection packets, so if there are any the extension files that you want to limit, just add the the extension files else to this layer 7 protocols such the above scripts.
Part II. Creating the video streaming connection packet per client and the queue tree rules that you give the priority as you like. Here the scripts that you can paste to the new terminal window, that make more easier.
If the above script doesn't works, try the second regexp in the layer 7 protocols such the script below!
I think this is the same method to create the connection packets like the download packets that using layer 7 protocols, that allow you to create more and more the connection packet that you wan along you can understand the regexp language
Part III : Creatingthe Online games connection packets per client together with queue tree rules and the priority of the connection packets, here is the scripts:
In this case we have create the online-games connection, using the port tcp and udp game that have used by the online games server. Therefore you must the online game ports that usually used. Here I collect the ports to be one before we can separate by IP address of the clients that you have. Then finally we can capture the online games packets in the queue tree rules for the priority and manage the bandwidth for this.
Part IV. Creating the browsing connection packets per client complete with queue tree rules and give you can see on the scripts below :
We still use the connection packets per client to make the browsing connection packets. Here we use the port 80 and 443 (HTTP and HTTPS), we define small bytes connection-bytes=0-1000000, that using the ports usually used when the client browse any url of the website.
Here we have just implemented "Full Bandwidth Management Parent Queue Tree", then you can customize the scripts with the interface of mikrotik router that you have use, the IP Address of the clients that you have, so that you can manage the queue tree rules as the final result. For more quickly you just need to copy all the scripts to the new terminal window of the winbox. So this is the connection Packets with divided into four main of the connection packets such as download, browsing, video streaming, and online games), the queue tree rules will capture the marking that we have created on the mangle rules and the queue tree will manage that packet mark. The result of the experiment method as shown like the tree pictures above! For more details you can see this article video that I have included!
For example If I have a totally the bandwidth internet connection is up to 2M, after i have tested by speed test, the bandwidth average is 512 kbps. It means that if I have 6 clients, be 512/6 = 86 kbps/clients normally, the ideal number is very small inappropriate for our client. If the bandwidth of up to 2 M calculated with 2000/6 to be around 334 kbps /clients, it can makes browsing and online game stuck if just only one client there who download and play streaming video, because the client spend almost all the average speed (512kbps) other clients will be especially problematic just for browsing or online game. In this case we need the priority to the fourth packets.
Full Bandwidth Management with the parent queue tree complete the lack of packets connection per client, especially to handle the internet network with many clients. The principle is equally divide the bandwidth to all the clients with bandwidth greater than that should be given as the limit bandwidth on each clients, in which we set Online Games, Browsing, Download, Video Streaming packets, connection packets. Well, for now I will make the Full Bandwidth Management using the parent queue tree. For more easily to make the complex rule, I will work with the scripts for more quickly.
Condition Starting:
Total Bandwidth : Up to 2 M
I have 8 Clients
Billing : 192.168.1.11
Client1 : 192.168.1.17
Client2 : 192.168.1.16
Client3 : 192.168.1.15
Client4 : 192.168.1.14
Client5 : 192.168.1.20
Client6 : 192.168.1.21
Master : 192.168.1.8
In-Interface : ether1
Out-Interface : wlan1
Address List
/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=MikroTik comment=""
Total Bandwidth : Up to 2 M
I have 8 Clients
Billing : 192.168.1.11
Client1 : 192.168.1.17
Client2 : 192.168.1.16
Client3 : 192.168.1.15
Client4 : 192.168.1.14
Client5 : 192.168.1.20
Client6 : 192.168.1.21
Master : 192.168.1.8
In-Interface : ether1
Out-Interface : wlan1
Address List
/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=MikroTik comment=""
1. Separating & Marking Connection Packets "Out & In" Globally
Marking all the connection packet out & in of the traffic mikrotik router, it is relatively depending on the interface that used. Connection packets out from local interface is connection packet In from public interface, it is download connection packet. And Out from local interface is In from public interface, It is upload connection packet. This is implemented on the script below!/ip firewall mangle add action=mark-connection chain=prerouting disabled=no in-interface=ether1 new-connection-mark=All-Inconn passthrough=yes comment="UPSTEAM CONNECTION" add action=mark-packet chain=prerouting connection-mark=all-inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM" add action=mark-connection chain=forward disabled=no in-interface=wlan1 new-connection-mark=All-Outconn passthrough=yes comment="DOWNSTEAM CONNECTION" add action=mark-packet chain=forward connection-mark=all-outconn disabled=no new-packet-mark=All-Outpkt passthrough=yes comment="DOWNSTEAM" /queue tree add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
We will focus on All-Outconn as you can see as the above scripts, the connection packets using chain=forward and out-interface=wlan1. From this marking we get All-Outpkt that we can separate again to the various kind of connection packets that we need.
2. Separating Download Connection Packets per Client IP
The general download packet All-Outpkt, we are going to separate it into connection packets per client IP address, to capture the connection download that used by the clients. It is implemented on the following scripts :/ip firewall mangle add action=mark-packet chain=forward dst-address=192.168.1.11 packet-mark=All-Outpkt new-packet-mark=Billing-pkt passthrough=yes comment="BILLING DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.17 packet-mark=All-Outpkt new-packet-mark=Client1-pkt passthrough=yes comment="CLIENT1 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.16 packet-mark=All-Outpkt new-packet-mark=Client2-pkt passthrough=yes comment="CLIENT2 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.15 packet-mark=All-Outpkt new-packet-mark=Client3-pkt passthrough=yes comment="CLIENT3 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.14 packet-mark=All-Outpkt new-packet-mark=Client4-pkt passthrough=yes comment="CLIENT4 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.20 packet-mark=All-Outpkt new-packet-mark=Client5-pkt passthrough=yes comment="CLIENT5 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.21 packet-mark=All-Outpkt new-packet-mark=Client6-pkt passthrough=yes comment="CLIENT6 DOWNSTREAM" add action=mark-packet chain=forward dst-address=192.168.1.8 packet-mark=All-Outpkt new-packet-mark=Master-pkt passthrough=yes comment="MASTER DOWNSTREAM" /queue tree add name=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Master parent=All-Bandwidth packet-mark=Master-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
The mangle scripts above included with the queue tree rules. From here we have just made the download connections packets per clients, such as
- Connection Packets Per Client : Billing-pkt, Client1-pkt, Client1-pkt, Client2-pkt, Client3-pkt, Client4-pkt, Client5-pkt, Client6-pkt, Master-pkt
3. Separating Download Packets Clients to Various Kind Connection Packets
The Connections packets per client that we have just made will divided into four kind connection packets such as browsing, online games, download, video streaming. We are going to make 4 kind of the connection packets. If you want to make the kind of connection packets else, you can define using layer 7 protocols.Part I : Creating the connection packets per client of download and setup the priority in queue tree rules as you wish, you can see the scripts below!
/ip firewall layer7-protocol add comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$" /ip firewall mangle add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=billing-dpkt passthrough=no packet-mark=Billing-pkt comment=Billing-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=no packet-mark=Client1-pkt comment=Client1-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=no packet-mark=Client2-pkt comment=Client2-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=no packet-mark=Client3-pkt comment=Client3-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=no packet-mark=Client4-pkt comment=Client4-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client5-dpkt passthrough=no packet-mark=Client5-pkt comment=Client5-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client6-dpkt passthrough=no packet-mark=Client6-pkt comment=Client6-Down add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=master-dpkt passthrough=no packet-mark=Master-pkt comment=Master-Down /ip firewall mangle add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=billing-dpkt packet-mark=Billing-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client1-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client2-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client3-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client4-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client5-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client6-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down" add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=master-dpkt packet-mark=Master-pkt protocol=tcp comment="Billing-Down" /queue tree add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Master-Down parent=Master packet-mark=master-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
Here we have used the connections packet per client and to make the download file extension connection packets, so if there are any the extension files that you want to limit, just add the the extension files else to this layer 7 protocols such the above scripts.
Part II. Creating the video streaming connection packet per client and the queue tree rules that you give the priority as you like. Here the scripts that you can paste to the new terminal window, that make more easier.
/ip firewall layer7-protocol add comment="" name=streaming regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$"
If the above script doesn't works, try the second regexp in the layer 7 protocols such the script below!
/ip firewall layer7-protocol add comment="" name=streaming regexp="videoplayback|video"
/ip firewall mangle add comment=Billing-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=billing-spkt passthrough=no packet-mark=Billing-pkt add comment=Client1-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client1-spkt passthrough=no packet-mark=Client1-pkt add comment=Client2-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client2-spkt passthrough=no packet-mark=Client2-pkt add comment=Client3-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client3-spkt passthrough=no packet-mark=Client3-pkt add comment=Client4-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client4-spkt passthrough=no packet-mark=Client4-pkt add comment=Client5-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client5-spkt passthrough=no packet-mark=Client5-pkt add comment=Client6-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client6-spkt passthrough=no packet-mark=Client6-pkt add comment=Master-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=master-spkt passthrough=no packet-mark=Master-pkt /queue tree add name=Billing-Streams parent=Billing packet-mark=billing-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Master-Streams parent=Master packet-mark=master-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
I think this is the same method to create the connection packets like the download packets that using layer 7 protocols, that allow you to create more and more the connection packet that you wan along you can understand the regexp language
Part III : Creatingthe Online games connection packets per client together with queue tree rules and the priority of the connection packets, here is the scripts:
/ip firewall mangle add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal" add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080 /ip firewall mangle add action=mark-packet chain=forward new-packet-mark=billing-gpkt passthrough=no src-address=192.168.1.11 packet-mark=gpkt comment=Billing-Game add action=mark-packet chain=forward new-packet-mark=client1-gpkt passthrough=no src-address=192.168.1.17 packet-mark=gpkt comment=Client1-Game add action=mark-packet chain=forward new-packet-mark=client2-gpkt passthrough=no src-address=192.168.1.16 packet-mark=gpkt comment=Client2-Game add action=mark-packet chain=forward new-packet-mark=client3-gpkt passthrough=no src-address=192.168.1.15 packet-mark=gpkt comment=Client3-Game add action=mark-packet chain=forward new-packet-mark=client4-gpkt passthrough=no src-address=192.168.1.14 packet-mark=gpkt comment=Client4-Game add action=mark-packet chain=forward new-packet-mark=client5-gpkt passthrough=no src-address=192.168.1.20 packet-mark=gpkt comment=Client5-Game add action=mark-packet chain=forward new-packet-mark=client6-gpkt passthrough=no src-address=192.168.1.21 packet-mark=gpkt comment=Client6-Game add action=mark-packet chain=forward new-packet-mark=master-gpkt passthrough=no src-address=192.168.1.8 packet-mark=gpkt comment=Master-Game /queue tree add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Master-Game parent=Master packet-mark=master-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
In this case we have create the online-games connection, using the port tcp and udp game that have used by the online games server. Therefore you must the online game ports that usually used. Here I collect the ports to be one before we can separate by IP address of the clients that you have. Then finally we can capture the online games packets in the queue tree rules for the priority and manage the bandwidth for this.
Part IV. Creating the browsing connection packets per client complete with queue tree rules and give you can see on the scripts below :
/ip firewall mangle add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Billing-pkt new-packet-mark=billing-bpkt protocol=tcp comment="BILLING BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client1-pkt new-packet-mark=client1-bpkt protocol=tcp comment="CLIENT1 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client2-pkt new-packet-mark=client2-bpkt protocol=tcp comment="CLIENT2 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client3-pkt new-packet-mark=client3-bpkt protocol=tcp comment="CLIENT3 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client4-pkt new-packet-mark=client4-bpkt protocol=tcp comment="CLIENT4 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client5-pkt new-packet-mark=client5-bpkt protocol=tcp comment="CLIENT5 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client6-pkt new-packet-mark=client6-bpkt protocol=tcp comment="CLIENT6 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Master-pkt new-packet-mark=master-bpkt protocol=tcp comment="MASTER BROWSING" /queue tree add name="Billing-Browsing" parent=Billing packet-mark=billing-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client1-Browsing" parent=Client1 packet-mark=client1-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client2-Browsing" parent=Client2 packet-mark=client2-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client3-Browsing" parent=Client3 packet-mark=client3-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client4-Browsing" parent=Client4 packet-mark=client4-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client5-Browsing" parent=Client5 packet-mark=client5-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Client6-Browsing" parent=Client6 packet-mark=client6-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name="Master-Browsing" parent=Master packet-mark=master-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
We still use the connection packets per client to make the browsing connection packets. Here we use the port 80 and 443 (HTTP and HTTPS), we define small bytes connection-bytes=0-1000000, that using the ports usually used when the client browse any url of the website.
Here we have just implemented "Full Bandwidth Management Parent Queue Tree", then you can customize the scripts with the interface of mikrotik router that you have use, the IP Address of the clients that you have, so that you can manage the queue tree rules as the final result. For more quickly you just need to copy all the scripts to the new terminal window of the winbox. So this is the connection Packets with divided into four main of the connection packets such as download, browsing, video streaming, and online games), the queue tree rules will capture the marking that we have created on the mangle rules and the queue tree will manage that packet mark. The result of the experiment method as shown like the tree pictures above! For more details you can see this article video that I have included!
Related Articles
What is In-Interface = ether1 ?
ReplyDeleteOut-Interface = wlan1 ?
In-Interface = ether1 = WAN ?
Out-Interface = wlan1 =LAN ?
In-Interface : local interface where clients are connected
DeleteOut-Interface : public interface, lead to the source internet connection
apakah tutorial ini bisa di terapkan untuk bandwidth 1M???
Deleteapakah saat browsing bersamaan dengan bermain game online, game_nya tidak ngelek...???
mohon pencerahan.... (maklum masih belajar)
Pertama anda harus benar2 mengerti alur dan pemisahan koneksi sesuai dengan konteks mikrotik dan jaringan anda. Setelah semua berada dalam jalurnya. Jika anda bermaksud memprioritaskan game online, berikan prioritas tertinggi, dengan bandwidth yang memadai. Kemudian jangan tentukan speed browsing,streaming,dan download pada queue treenya, biarkan parent queue tree yang mengaturnya menjadi satu pada tiap2 client dengan sisa speed yang menurut anda aman. Jadi ini seperti mengadu domba yang lainnya!
Deletethe out is lan while in is wan
DeleteWhat is In-Interface = ether1 ?
DeleteOut-Interface = wlan1 ?
In-Interface = ether1 = WAN ? internet dari ISP
Out-Interface = wlan1 =LAN ? jaringan lokal
apakah ini benar??
Itu ke balik mas!
DeleteIn-Interface = ether1 = lan = local
DeleteIn-Interface = wlan1 = wan = public
Hottest South Indian Actress Photos
DeleteBollywood Hot Actress Photos
does it works with 200 clients and 100 Mb / s?
ReplyDeleteI think it is depending on the ability of mikrotik routerboard especially to handle the scripts that would be very long if you want to implement it by single routerboard.
ReplyDeletecan you help me i have 10 clients & 1 server the video you share is for 8 clients,,help me pls
Deleteoww 0ne thing & i have 10mbps internet connection
Deleteif my clintes mamualy add in simple que than how can i applied this priority method
ReplyDeletei am understand english not much
ReplyDeletei am use this method on mt pc Fix Total Bytes Dynamic Simple Queue Mikrotik with diffrent rate limit like 512kb 256kb 1mb etc now i want to use this method with my old client setting plz guied
regards
I am not so clear, what is the point of your problem?
Deletehy
ReplyDeletei am using this method for control speed trfic { Simple Way Limiting Bandwidth on Mikrotik} and add my all client with diffrent speed value like 256k,512k,1m,..etc
now i want to use your new method how can i used this with my old value of configration
guied me with some shourt MT scripts
regards
does it means that you want to apply this method with simple queue because you don't want to use queue tree ?
Deleteyes Sir :)
Delete/ip firewall layer7-protocol
ReplyDeleteadd comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
/ip firewall mangle
add comment=Billing-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=billing-dpkt passthrough=no connection-mark=Billing-conn
add comment=Client1-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client2-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client3-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client4-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client5-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client5-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client6-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client6-dpkt passthrough=no connection-mark=Client1-conn
add comment=Master-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=master-dpkt passthrough=no connection-mark=Master-conn
/queue tree
add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Master-Down parent=Master packet-mark=master-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
litel confiused here in mangle rule all 1 2 3 4 5 6 clint end on connection mark as name client1
other hand master and billing connection-mark as billing and master
oh I just see any mistake here i am really sorry! the script should be like this or try review it again, i have already fix it!
Delete/ip firewall mangle
add action=mark-connection chain=forward comment="Billing" disabled=no dst-address=192.168.1.11 new-connection-mark=Billing-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Billing-pkt passthrough=yes connection-mark=Billing-conn
add action=mark-connection chain=forward comment="Client1" disabled=no dst-address=192.168.1.17 new-connection-mark=Client1-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client1-pkt passthrough=yes connection-mark=Client1-conn
add action=mark-connection chain=forward comment="Client2" disabled=no dst-address=192.168.1.16 new-connection-mark=Client2-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client2-pkt passthrough=yes connection-mark=Client2-conn
add action=mark-connection chain=forward comment="Client3" disabled=no dst-address=192.168.1.15 new-connection-mark=Client3-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client3-pkt passthrough=yes connection-mark=Client3-conn
add action=mark-connection chain=forward comment="Client4" disabled=no dst-address=192.168.1.14 new-connection-mark=Client4-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client4-pkt passthrough=yes connection-mark=Client4-conn
add action=mark-connection chain=forward comment="Client5" disabled=no dst-address=192.168.1.20 new-connection-mark=Client5-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client5-pkt passthrough=yes connection-mark=Client5-conn
add action=mark-connection chain=forward comment="Client6" disabled=no dst-address=192.168.1.21 new-connection-mark=Client6-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Client6-pkt passthrough=yes connection-mark=Client6-conn
add action=mark-connection chain=forward comment="Master" disabled=no dst-address=192.168.1.8 new-connection-mark=Master-conn passthrough=yes connection-mark=All-Outconn
add action=mark-packet chain=forward comment="" new-packet-mark=Master-pkt passthrough=yes connection-mark=Master-conn
in game script are different?it shows on the video it is in mark connection but the script was in mark packets?
DeleteHi Ketut Agus Suardika I Want Open Speed Programs Chat (skype / yahoo mail / facebook ) Possible Settings
ReplyDeletePossible Settings (drop Internet Download Manager )
ReplyDeletemikrotik v 6.5
if tx rate 512k and rx rate 512k
ReplyDeleteand 1m/1m
/ip firewall mangle
add action=mark-connection chain=forward comment="BILLING-BROWSING-CONN" {{{{connection-bytes=0-1000000 }}}} how many bytes???
1 byte = 8 bits
Delete1 kilobyte (K / Kb) = 2^10 bytes = 1,024 bytes
1 megabyte (M / MB) = 2^20 bytes = 1,048,576 bytes
connection-bytes=0-1000000 usually when the user browsing is not spend greater than 1 M
Les Mafish Reply to topic
ReplyDeleteI am sorry! so long to answer about many questions . I'll be write the new article as a reference, but be patient!
ReplyDelete/ip firewall layer7-protocol
ReplyDeleteadd comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
Kenapa di Mikrotik RB750G tidak terbaca oleh Queue Tree?. Sehingga untuk download tidak terlimit.
Coba cek manglenya mas! kl gak nangkep juga, pengalaman yang pernah saya alami adalah ada routing list yang berwarna merah (tidak terdifinisi dengan jelas)
Deleteatau coba pake metode pembagian paket saja dari artikel ini http://agratitudesign.blogspot.com/2013/12/perfection-bandwidth-management-parent.html
DeleteI am using Mikrotik RB411Ah (v5.5) as Access Point bridge for point to multipoint wireless connections.
ReplyDeleteinterface is
ether1--------------> connected to internet server
wlan1----------------> wireless card connected to Customer Point Equipments
bridge1------------>?
Internet as it is , is working fine.
I tried to put Priority list and queue tree by using the script given above
The script has added mangle list , queue sub tree. (seems fine at first glance). But I do not see any movement in queues or ip/firewall/mangle....no input/output byte or packet.
Kindly guide me what went wrong? and what should be done to get it running.
*****script starts****
/ip firewall mangle
add action=mark-connection chain=prerouting comment="CONNECTION-IN" disabled=no dst-address-list=!
MikroTik in-interface=ether1 new-connection-mark=All-Inconn passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=All-Inconn disabled=no new-packet-
mark=All-inpkt passthrough=yes
add action=mark-connection chain=forward comment="CONNECTION-OUT" disabled=no new-connection-
mark=All-Outconn out-interface=wlan1 passthrough=yes
add action=mark-packet chain=forward comment="" connection-mark=All-Outconn disabled=no new-packet-
mark=All-Outpkt passthrough=yes
/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=1 max-limit=2M
I used only names for clients no master or billing.
Ok that means, you have used wlan1 as local interface and ether1 as public interface
Deleteassuming that you have local network with the ip 192.168.1.0/24 you make the address-list at first
/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=Mikrotik comment=""
this is how you make the connection packets downsteam and upsteam
/ip firewall mangle
/ip firewall mangle
add action=mark-connection chain=prerouting dst-address=!MikroTik in-interface=wlan1 new-connection-mark=All-Inconn disabled=no passthrough=yes comment="CONNECTION-IN"
add action=mark-packet chain=prerouting connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM PACKETS"
add action=mark-connection chain=forward out-interface=ether1 new-connection-mark=All-Outconn disabled=no passthrough=yes comment="CONNECTION-OUT"
add action=mark-packet chain=forward connection-mark=All-Outconn new-packet-mark=All-Outpkt out-interface=ether1 disabled=no passthrough=yes comment="DOWNSTEAM-PACKETS"
then continue it with your purposes
Maaf,, Bru belajar,,Maksudnya script "dst-address-list=!MikroTik" itu apa?
ReplyDeleteMaksudnya selain ip router dari network anda, atau selain ip gateway
Deletewah artikelnya bagus mas.
ReplyDeletesaya suka setingan seperti ini
tapi saya masih belajar dan disaya ada 2 Line masing2 Modem A.3Mb buat browsing Modem B.1Mb buat Game Ane selama ini statik routing,
kira2 kalau setingan di atas saya mulai dari mana aja ya mas ?
Menurut saya ini menjadi lebih rumit, harus masuk ke settingan dual wan load balancing untuk hasil yang optimal, sebelum dipisahkan menjadi paket2 koneksi, chain yang dipakai dalam mangle harus memasuki proses dalam router, jadi chainnya berbeda. Ini bayangan saja, akan tetapi maaf saya belum pernah mempraktekkan dual wan load balancing!
Deletemas itu yang magle download conetion marknya emang ke client 1 semua ya?
ReplyDeleteMaaf baru bisa jawab, dua bulan terakhir ini saya banyak permasalahan kerja yang saya harus saya atasi. Makasi mas atas koreksinya, ada kesalahan penamaan disana, diawal lagi. Saya akan perbaiki, maksudnya disana client1,2,3,4,5 . Terima kasih!
Deleteselamat malam mas, saya sangat tertarik dengan sistem ini untuk digunakan di warnet saya. yang jadi permasalahannya saya baru n pengen belajar tentang mikrotik. saya coba cari cari dan saya lebih suka dengan sistem ini. sekarang ini ada 15 pc. 1pc biling, 9 pc untuk game online pb, dragonnest, lostsaga dll. dan 5 pc untuk browsing. dan ke depan rencananya mau nambah pc untuk game n browsing biar pas 20 pc. untuk formatnya bagaimana. kalau sekarng saya memakai kecepatan 2M.saya mohon pencerahannya untuk 15 pc saya ini dengan kecepatn 2M. terimakasih sebelumnya.....
ReplyDeleteapa tinggal copy paste script di atas udah langsung bisa di pake ? tadi dari script di atas gak ada ip masing² client maupun billing ? bisa tolong di jelasin gak om .makasih
ReplyDeleteHarus dimengerti dulu mas, jangan dicopy paste mentah, harus disesuaikan nama2 interfacenya, pokoknya yang berhungan dengan setting jaringannya!
Deletescript "dst-address-list=!MikroTik". Mikrotik apa??? ip lokal bukan?? Tolong jelaskan
ReplyDeleteOk biar tidak bingung saya sudah lengkapi dengan ini
Delete/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=Mikrotik comment=""
Koneksi upload adalah koneksi berasal dari client melalui in-interface=ether1 atau lan1, atau apapun nama yang anda berikan, yang berasal dari network client masuk interface local keluar keluar dari interface public, tentunya tujuan dst addressnya yang bukan network/local. Dalam hal ini !MikroTik
hello as I do for client 100
ReplyDeleteHi i am using pppoe connections with profile 1 and profile 2 ... profile 4. each profiles have different speed.
ReplyDeleteso the question is how can i make your client 1 works with profile 1...etc
please replay to me any thing
Mas, salam kenal.
ReplyDeleteSaya pakai 2 line speedy, dan di mikrotik saya sudah di setting pakai ECMP Load balancing, kalau saya mau masukkan konfigurasi seperti mas gimana ya di firewall mangle nya?
http://wiki.mikrotik.com/wiki/ECMP_load_balancing_with_masquerade
Di mikrotik saya udah ada marking supaya bandwith terbagi ke kedua line. Apakah langsung bisa di merge dengan setingan ini?
Untuk dual wan load balancing agak berbeda sedikit, saya sudah membuat catatan lagi pada artikel ini
Deletehttp://agratitudesign.blogspot.com/2014/04/ecmp-load-balancing-failover-with-proxy.html
bli kalo setingan pembagian untuk 2M , 12 computer gimana ya....
ReplyDeletetolong pencerahnya dalam membagi rata bandwisch
pembagian sama rata bandwisch tiap komputer brp K
Deletemakasih bli..
kalo topologi bli kan 8 computer dengan 220k 220k 256k dan 160k
wah mantap, terima kasih bro atas sharing ilmu dan konfigurasinya, indahnya saling berbagi, sudah saya terapkan di warnet saya dengan sedikit merubah ip address dan menambah jumlah client nya, setelah di test ok dan cukup bagus untuk memisahkan ke 4 jaringan yang berbeda. (y) :) hanya bandwidth nya kekecilan, jdi saya gedein saja dikit karna menggunakan proxy
ReplyDeleteYa itu adalah penyesuaian terdahap jaringan yang mutlak diperlukan, apalagi jika menggunakan proxy akan lebih leluasa. Adalagi mas dns server bisa membuat browsing makin mantap. Dari pengalaman saya ni mas, proxy sangat membantu dengan refresh patternnya dari cachenya, sedangkan dns server membantu kecepatan resolving untuk menemukan alamat tujuan, terutama pada saat traffic padat
Deleteboleh tau saya script nya untuk DNS??
DeleteHi. i keep getting this error "input does not match any value of parent" what should i do?
ReplyDeleteI am sorry, any a little mistake from the earlier script, i've already fix, you can try it again!
Deletebagaiman menentukan ip yang akan dijadikan billing dan master?, apakah ip yang dijadikan billing dan master adalah ip yang khusus( tidak digunakan oleh client)
ReplyDeleteMaster dan billing adalah client juga, cuma tidak saya sewakan dan masih berada dalam network yang sama bukan, kl tidak akan sulit dijadikan billing untuk komunikasi sharing printer maupun file.
DeleteCould you update your script for Mikrotik v 6.+ ?
ReplyDelete/ip firewall layer7-protocol
ReplyDeleteadd comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
/ip firewall mangle
add comment=Billing-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=billing-dpkt passthrough=no connection-mark=Billing-conn
add comment=Client1-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client2-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client3-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=no connection-mark=Client1-conn
add comment=Client4-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=no connection-mark=Client1-conn
add comment=Master-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=master-dpkt passthrough=no connection-mark=Master-conn
Saya ingin tanya .... itu yang saya tebalkan tulisannya. apa memang harus sperti itu ? untuk klien 1-6 itu menjadi client1-conn semua ?
sedangkan untuk billing dan master mempunyai nama lain, master-conn dan billing-conn?
Apakah harus seperti itu atau ...
Mohon penjelasannya.
Maaf ada kesalahan dari orat-oret saya. Namanya di bedain saja, itu adalah koneksi perclient yang akan dipisahkan mejadi koneksi download per client. harus dibedakan nama2nya, terserah namanya bisa diganti dengan yang anda inginkan. yang terpenting itu adalah koneksi yang menuju kemasing2 client pengguna internet
Deletemakasih atas ilmunya..
ReplyDeleteada yg ingin saya tanyakan ,caranya biar bandwith upload di loss gmn Om?
Ini cara menangkap koneksi dan packet upload, in-interface=ether yaitu interface/terminal ethernet mikrotik yang menuju ke jaringan client
Delete/ip firewall mangle
add action=mark-connection chain=prerouting dst-address=!MikroTik in-interface=ether1 new-connection-mark=All-Inconn disabled=no passthrough=yes comment="CONNECTION-IN"
add action=mark-packet chain=prerouting connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM PACKETS"
Karena disini memakai chain=prerouting, maka parent queue treenya menggunakan global-in, berikan nilai maximum yang dari "max-limit" sesuai dengan kapasitas maximum speed upload dari bandwidthnya
/queue tree
add name="Upload" parent=global-in packet-mark=All-inpkt queue=default max-limit=2000k
Selamat Malam mas ketut, ada yang mau saya tanyakan di sini, mengenai script utk melimitasi download bandwith pada client
ReplyDeleteini adalah salah satu script anda yg sudah sy modifikasi
/ip firewall layer7-protocol
add comment="" name=download regexp="^.*get.+\\.(msi|exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
/ip firewall mangle
add comment=Client10-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client10-dpkt passthrough=no connection-mark=Client10-conn
/queue tree
add name=Client10-Down parent=Client-10 packet-mark=client10-dpkt queue=default priority=6 limit-at=10k max-limit=50k burst-limit=256k burst-threshold=25k burst-time=10s
yang ingin saya tanyakan adalah : kenapa saat saya mencoba melakukan download [tanpa menggunakan download manager] download speednya masih bisa di atas 50KB/s? apakah ada kesalahan pada script yang sudah saya modifikasi? terimakasih sebelumnya
Berarti ada kesalahan marking di manglenya, sebelum membuat rule queue tree, coba diperiksa dulu apakah mangle rulenya bergerak pada saat digunakan. Dan yang paling penting adalah fondasi awal ini harus bekerja dulu.
Delete/ip firewall mangle
add action=mark-connection chain=prerouting dst-address=!MikroTik in-interface=ether1 new-connection-mark=All-Inconn disabled=no passthrough=yes comment="CONNECTION-IN"
add action=mark-packet chain=prerouting connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM PACKETS"
add action=mark-connection chain=forward in-interface=wlan1 new-connection-mark=All-Outconn disabled=no passthrough=yes comment="CONNECTION-OUT"
add action=mark-packet chain=forward connection-mark=All-Outconn new-packet-mark=All-Outpkt disabled=no passthrough=yes comment="DOWNSTEAM-PACKETS"
Selamat siang mas ketut, benar apa kata mas ketut, ternyata ada kesalahan pada mangle milik saya, saya salah memasukkan in&output interfacenya, hehe.. setelah saya perbaiki, semua berjalan normal!
Deleteterimakasih banyak sebelumnya mas ketut, semoga sukses!
Saya senang mendengarnya, berhasil tidaknya dalam penerapannya tertunya karena pemahaman dari anda juga terhadap kondisi jaringan yang anda miliki! Terima kasih juga mas atas kunjungannya!
DeleteOm mau tanya kenapa ya ketika client lg browsing masuknya ke paket streaming ya?
ReplyDeletemohon pencerahanya ..
ters utk pengaturan limit at & max limit misal sy kasih 1M, burst limit sama burst treshold yg tepat brp?
makasih
Ok mas! kl begitu mungkin kesalahan alur pada marking koneksinya. Mas pake mikrotik versi qos ros berapa nih?. Boleh saya tahu nama interface yang dipakai? kemudian maximum bandwidthnya dan paket apa saja yang ingin dibedakan
DeleteOs level5 mikrotik v.5.26
ReplyDeletebandwith 4M
either1=isp
either2=lan
management sm ky model Om ketut
Saya kira sih sudah jelas ya apa yang ada dalam artikel. Tetapi untuk pengujian pada sistem network lain, saya ingin tahu juga, clientnya menggunakan static ip semua, apa ada untuk hotspot juga? kl static ip semua berikan saya ip2nya!
DeleteRange ip client 192.168.100.10~192.168.100.46
ReplyDeleteip mikrotik 192.168.100.1
client menggunakan static ip Om..
makasih
Masuk ke satu Thread Comment saja ya biar lebih fokus seperti ini! clientnya memang jumlahnya 25 ya? 4M jika dibagi 25 client itu sekitar 160k/client. Apa ini untuk warnet dengan game online?
Deleteselamat malam om agus
ReplyDeletesaya mau tanya diwarnet saya komputer billing langsung kesalah satu port mikrotik dan untuk komputer client melalui switch sebelum terhubung dengan mikrotik
apakah untuk settingan diatas perlu perubahan
dan satu pertanyaan lagi client saya ada 12pc apakah untuk penambahan dari 8pc client diatas hanya perlu ditambahkan dan disesuaikan dengan interfacenya masing2?
Kl menurut saya yang kita pedulikan dalam pengaturan bandwidth kan pada interface yang terhubung ke client, biar tidak bingung abaikan dulu billing jika memakai interface lain dari mikrotik apa lagi networknya berbeda (perlu tambahan rule). Nah pada metode ini kita hanya fokus pada 2 interface yang digunakan yaitu public dan local network
DeleteKarena ini pengaturan bandwidth per client, tentu harus ditambahkan per ip client dalam satu network mask.
Deleteterima kasih om agus atas replynya
ReplyDeletesangat membantu sekali ilmu nya
tinggal saya praktekan
sekali lagi terima kasih
Sama2 dik...selamat berkreasi!
DeleteI am new in mikrotik and i have being reading all your wonderful script and grab many knowledge.please how do limit bandwidth for our four cameras in different subnet that is taking a lot of bandwidth.i have try simple queues but its didn't work..can i use the script above?..please reply as soon as possible..i am interested in this router os after limiting my knowledge in cisco equipment.
ReplyDeleteBli bantu cara membagi bandwith nya secara otomatis
ReplyDeleteTerimah kasih
mas agus selamat malam? untuk semua script saya coba dan berhasil dijalankan, hanya saja untuk queue tree client game tidak menunjukan aktivitas average bandwith yang terpakai dan hanya diam di 0 saja
ReplyDeleteberikut untuk scipt yang saya pakai? apakah ada kesalahan ?
berikut script saya yang saya pakai
/ip firewall mangle
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080
/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=billing-gpkt passthrough=no dst-address=192.168.1.99 packet-mark=gpkt comment=Billing-Game
add action=mark-packet chain=forward new-packet-mark=Operator-gpkt passthrough=no dst-address=192.168.1.100 packet-mark=gpkt comment=Operator-Game
add action=mark-packet chain=forward new-packet-mark=client1-gpkt passthrough=no dst-address=192.168.1.101 packet-mark=gpkt comment=Client1-Game
add action=mark-packet chain=forward new-packet-mark=client2-gpkt passthrough=no dst-address=192.168.1.102 packet-mark=gpkt comment=Client2-Game
add action=mark-packet chain=forward new-packet-mark=client3-gpkt passthrough=no dst-address=192.168.1.103 packet-mark=gpkt comment=Client3-Game
add action=mark-packet chain=forward new-packet-mark=client4-gpkt passthrough=no dst-address=192.168.1.104 packet-mark=gpkt comment=Client4-Game
/queue tree
add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Operator-Game parent=Operator packet-mark=Operator-gpkt queue=default priority=1 limit-at=3M max-limit=3M burst-limit=3M burst-threshold=1M burst-time=2s
add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default priority=1 limit-at=512k max-limit=512k burst-limit=512k burst-threshold=256k burst-time=2s
add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default priority=1 limit-at=512k max-limit=512k burst-limit=512k burst-threshold=256k burst-time=2s
add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default priority=1 limit-at=512k max-limit=512k burst-limit=512k burst-threshold=256k burst-time=2s
add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default priority=1 limit-at=512k max-limit=512k burst-limit=512k burst-threshold=256k burst-time=2s
mohon dibantu om agus sebelumnya terima kasih
DeleteMaaf sebelumnya jika respon saya terasa lama, saya terlalu asik melakukan eksperiment. Apakah rules untuk paket jenis koneksi lain bs berjalan? Game apa yang dijalankan? apakah portnya sudah dimasukkan? Berusahalah mencari update terakhir dari port game yang digunakan. Disini saya hanya melakukan test untuk game kesayangan saya, lostsaga, dan ini seharusnya berjalan. Namun yang terpenting jika bandwidth sudah mulai habis, game tidak akan bs berjalan dengan baik/lag, mau tidak mau kita kita harus menekan video streams dan download. Jika perlu kita harus membuatkan rule baru untuk packet downsteam yang lebih besar dari 1M
Deleteom agus terima kasih atas replynya, untuk rule download, streaming dan browsing berjalan dengan normal, untuk testing game online yang saya jalankan sama dengan game om agus jalankan: lost saga dan setelah pengecekan ulang port udp dan tcp lom dimasukan, tetapi untuk game Point Blank dan RAN Online yang sudah diinput portnya tetap tidak jalan dan tidak menunjukan aktivitas average bandwith.
Deletedan saya mencoba melakukan perubahan queue tree-clientgame3, tab general - packetmark = saya ubah menjadi gpkt, dan setelah diubah baru bisa berjalan normal dan average bandwith menunjukan aktifitas
sekian dan terima kasih atas bantuannya
Terima kasih kembali atas masukan! Good Luck!
DeleteHi,
ReplyDeleteMy LAN is 192.168.1.0/24, all PC gets DHCP IP. Using PCQ i managed its bandwidth. Now i want to give different Bandwidth to my 2 PC. Is it possible..?
Thanks in advance.
bisa di seting ke simple quee gk pak
ReplyDeleteHello
ReplyDeleteThere is a problem with me in mikrotik
How can I prevent some malicious network of customer use Mac
Surfs the Internet and enter freely
Where Mac Ip spam equals Mac client and Ip
If you allow Avodona
Thank you
https://drive.google.com/?tab=wo&authuser=0#my-drive
Bli untuk menambang port game online gi mana yah?
ReplyDeleteAtau bli punya script settingan yang ini untuk port game online yang lengkap?
Terima kasih sebelumnya
Dan ini maksnya apa yang "Mikrotik"
ReplyDeleteadd action=mark-connection chain=prerouting dst-address=!MikroTik
Bli Cara nambahin port game onlinenya gi mana? lalu untuk "add action=mark-connection chain=prerouting dst-address=!MikroTik" di kasih IP berapa? dan mangle untuk game dan streaming ko ga ada aktifitas yah, pdahal udah coba setting ulang ampe 3x tetep saja.
ReplyDelete/ip firewall address-list add address=192.168.1.0/24 disabled=no list=MikroTik comment=""
Deleteitu command untuk add address-list
Terus untuk step 1 line 2 ada kesalahan command
add action=mark-connection chain=prerouting dst-address=!MikroTik in-interface=ether1 new-connection-mark=All-Inconn disabled=no passthrough=yes comment="CONNECTION-IN"
Harusnya dst-address-list=!MikroTik (kurang -list nya)
Mantap sekali agan ini, settingan ini sama dengan punya saya (ini juga temen yg settingin) kalo punya agan lebih detil. Gan kalo untuk hotspot gimana gan tapi masih tetep satu settingan dengan Parent Queue Tree ini, Mohon pencerahannya, kalo berkenan dengan script di atas supaya ane juga bisa memahami. hatur nuhun gan.
ReplyDeletePak kalau settingan NAT dan ROUTE di mikrotiknya yang standard atau msti dirubah lagi pak?? soalnya yg direview cuma mangle sama queue tree saja
ReplyDeletedoes it work with doul wan pcc method settings???
ReplyDeleteNice post thanks for share
ReplyDeleteWeb page development
Php Tutorial
i have added this script and its fine.But there are lot of user and i have to scroll up/down to see red/yellow mark. now i have 40 user and i want to see only the red/yellow mark packet/user. how can i use filter to show only red & yellow sign mark.
ReplyDeleteSelamat Pagi Pak Bos Ketut Agus Suardika :D
ReplyDeleteSaya ingin bertanya pak tentang settingan tersebut, dengan memakai settingan tersebut apakah game online seperti point blank tidak akan lag atau putus-putus, mohon pencerahannya pak bos :).
Terima kasih.
selamat siang/malam Bli...
ReplyDeletemau nanya, saya blm mengerti maksud dari Billing dan Master fungsinya untuk apa? terus IP yang digunakan oleh Billing dan master itu IP ether2 (LAN)ya?
Terima kasih sebelumnya
Billing itu computer billing warnet mas bro
DeleteMaster, mungkin ada PC/Computer khusus buat jalanin update game
Blitut kenapa queues saya nggak mau pisah pisah ya.. semuanya masuk di queues client browsing biarpun saya lagi streaming video.. dimana nya kira kira kesalahan nya bli.. mohon bantuannya. suksma.
ReplyDeleteGan saya masih pemula, itu terus setingan ip --> addressnya gimana? di mikrotik ane ether1 public, ether2 local, apa ada yang salah? ip address 192.168.1.2/24 ke ether 1, ip address 192.168.10.1/24 ke ether2, apakah ini sudah bisa digunakan? lalu setiap client harus di setting ip adress sesuai di mangle kah? mohon maaf jika bahasa saya berbelit-belit... mohon bantuanya...
ReplyDeletethere is a mistake on Step 1 line 4
ReplyDeleteadd action=mark-connection chain=forward in-interface=wlan1 new-connection-mark=All-Outconn disabled=no passthrough=yes comment="CONNECTION-OUT"
change in-interface to out-interface (the interface that connected to your ISP/upstream)
Bli.. saya sudah mengikuti postingan dan tutor dari Bli... tapi Limiter saya yang berjalan hanya pada browsingnya saja Bli, ktika saya mencoba untuk stream, limiternya tetep masuk di browsing bkn di stream Bli, sama jga dengan download tetep masuk di browsing Bli bukan di download Mohon Pencerahannya Bli...
ReplyDeleteIni Contoh Config an Milik Saya Bli
http://www.tusfiles.net/dwxtk0jbyfbe
sama maslah saya dengan Rendika Yoga Gan
ReplyDeletehttp://www.4shared.com/photo/rtJhd91aba/Stems.html?
ReplyDeletehttp://www.4shared.com/photo/0WpjkuMYba/Warnet.html?
ini gan previewnya,, down, Streams, sama game nya ngga jalan.
Selamat pagi,
ReplyDeleteUntuk script
/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=1 max-limit=2M
Apakah parent=global-out dan global sama saja?
karena pada winbox saya tidak ada pilihan global-out hanya ada plihan global saja
terimakasih
Om agus, apakah bandwith management cukup untuk trafic upload saja (global out) ?
DeleteBisa, mengambil definisi global-out sudah mewakili untuk bisa mendifinisikan jenis2 upsteam dan downsteam lainnya!
DeleteOh ok om agus, maklum selama ini saya cuman pake simple queue
DeleteQoS RoS v6
DeleteNo more global-in and global-out, replaced by a "global" located after the "input" and at global-out position
Simple queue is a specific process, located after "global".
It is not so different, Just use global for upsteam and downsteam, it is more effective packet flow
Bli Mohon Pencerahan Limitan saya Yang Berjalan Cuma Brosing saja Stream Download sama Game nya g berjalan Ini config dari Bli Yang sudah saya Edit...
ReplyDeletehttp://www.tusfiles.net/dwxtk0jbyfbe
Terima Kasih Bli, Ternyata Config Bli memang Berhasil, cuma saya yang salah implementasi di Router saya.... sekali Lagi Terima Kasih, Lumayan dapat ilmu yang tinggi saat masih SMK
ReplyDeleteUntuk Limit Game Itu Contoh Gamenya Kayak Apa aja Bli ?
Sorry Newbie
Selamat sudah bisa menemukan permasalahannya sendiri, terkadang bisa dipengaruhi banyak faktor, disinilah letak analisa dan main koncept diperlukan, agar tidak menjadi runyam. Game sebenarnya yang paling sensitif, artinya tidak melingkupi scara menyeluruh. Disamping Game Online adalah server yang sangat sangat dinamis, rentan cheat, crack, maupun hack. Untuk alasan security mereka sering mengubah2 system mereka. Sebenar yang mengetahui secara tepat adalah programmer gamenya sendiri yang memberikan referensi port yang aman menurut mereka, dengan demikian kita bisa melakukan forward secara efektif.
DeleteContoh gamenya Point Blank (port 39190,40000-400010) dan steam game (port 27000-27030). Untuk port yang lainnya yang ada di settingan om agus, saya gak kenal game apa, sepertinya sih game gemscool lainnya( LS, DN, dll)
DeleteSekalian tanya Om Agus, tentang penamaan saja, kenapa koneksi upload disebutnya "connection-in", "all-inconn"(mark connection), "all-inpkt"(mark packet) dan kenapa koneksi download dinamakan "connection-out","all-outconn", "all-outpkt"?
Soalnya pemahaman saya malah sebaliknya, koneksi upload yang keluar (out) koneksi download yang masuk (in).
Pemahaman saya salah ya? Maaf newbie. :D
CONNECTION-IN maksudnya koneksi yang terjadi karena permintaan dari internal network, ini adalah koneksi yang berhubungan paket2 upload yang dimulai dari in-interface local dan akan keluar dari out-interface public oleh karena itu pada version 5 queue tree rules untuk upload menggunakan parent global-in. Dan ini berlaku sebaliknya untuk paket download
ReplyDeletesalam om agus
ReplyDeletewarnet sya ada 20 pc , 5 buat browsing lainya buat game..
saya akan coba script di atas..mohon arahan ya kalo ada salah
" yang tak akan pernah mati adalah ilmu dan amal yang bermanfaat bagi sesama "
salam
bocah rowo
salam om agus :)
ReplyDeletesaya mau nanya ini script jalan gk di versi 3.30?
satu lagi di bagian
add action=mark-connection chain=forward in-interface=wlan1 new-connection-mark=All-Outconn disabled=no passthrough=yes comment="CONNECTION-OUT"
untuk interfacenya menggunakan in-interface atau out-interface?
soalnya kalau dilihat di screenshootnya om agus, pakai yang out-interface
trimakasih
salam
Achmad
i have more dan 100 clients how .. i apply this to them
ReplyDeletetraffik sudah jalan pak tapi ketika main game lost saga kok trafiknya masuk ke client browsing ya, kok tidak masuk ke client games, mohon petunjuknya
ReplyDelete/ip firewall mangle
ReplyDeleteadd action=mark-packet chain=forward dst-address=192.168.1.0/24 packet-mark=All-Outpkt new-packet-mark=Billing-pkt passthrough=yes comment="BILLING DOWNSTREAM"
kalau ip di set seperti editan saya work ndak mas
Bli,,, untuk magle dan queue tree kok tidak jalan ya,,tp di upsteem dan downsteem cconetion jalan.. kira2 apanya ya bli.. untuk ip.192.168.1.x saya ganti ip saya 192.168.3.2 dan ether 1 serta wan1 sudah benar. tolong bls bli
ReplyDeleteHello, I have a mikrotik that I got 2meg/2meg from my provider. But I want want my lan (ether2)users with ip range of 192.168.0.1/24 to share the bandwidth evenly so that one user will not use all the assigned bandwidth to the detriment of others. I want it to be shared for like 20 or 30 users on the lan so that each will be browsing at the same speed. while my hotspot will then share the 1meg/1meg which is on ether3. How do I set and priotirize the bandwidth so that browsing will have higher prioroity than dopwnloading
ReplyDeletebli saya sudang menyetik mikrotik menggunakan settingan bli yang terdapat di script tersebut.saya sudah mengganti interface dan ip address bli dengan interface dan ip yang saya gunakan....tetapi setelah dijalankan kecepatan per client tidak ada yang berjalan semua.masih 0 kbps semua bli.saya menggunakan mikrotik rb750.MOHON BANTUANNYA BLI!!!!!!
ReplyDeleteEther LAN itu yang mana ya ether 1 atau wlan1?
ReplyDeletegood day sir,my ISP connection is dynamic..meaning my IP addresses keep renewing every time i started my modem so from this point how should i configure my mikrotik routerboard? i have 20 clients and 1 master PC, id like to limit them all equally..
ReplyDeletegood day sir, I've been reading a lot about mikrotik on your blog. can this Full Bandwidth Management be deployed with multiple wan? and how? thank you.
ReplyDeletegan tehnik peng hitungan bandwithnya itu gimana sih gan. bandwith agan 2M kok bisa masing2 client mendapat 256k.
ReplyDeletesaya memiliki bandwidth 20mb dan 20 komputer client. brp bandwidth yang sebaiknya saya bagi untuk game, browsing, download, streaming per client nya. terima kasih
ReplyDeleteterima kasih atas infonya
ReplyDeletekalau sempat kunjungi http://whussaya.blogspot.co.id/
I am confusing about two things:
ReplyDelete1-passthrough=No Or yes
2-connection-bytes=0-1000000
mas agus saya mau menanyakan kalo seandai nya isp terpisah dengan lokal dan internasional buat nya apakah seperti itu, isp lokal saya 9M dan internasional saya 6M sdix cuman 5M buat nya harus seperti apa ya mas tolong di bantu , pc yang di gunakan sekarang berjumlah 60 pc + 1 pc billing dan 1 pc server
ReplyDeleteI understand what you bring it very meaningful and useful, thanks.
ReplyDeleteSignature:
i like play happy wheels demo online and play happy wheels games full and friv , girlsgogames , games2girls
bagaimana cara penerapannya kalo memakai load balancing 3 line speedy
ReplyDeleteHi. i keep getting this error "input does not match any value of parent" what should i do?
ReplyDeletehi sir how to apply this method in dual isp? pls reply sir im newbe only in mikrotik, my routerboard is rb941 haplite.
ReplyDeleteHi
ReplyDeleteCan you rework the script for me ... ? I hope you help me because I 'm not an expert networks.
This is information about my router :
Router :RB2011U
input :wan1,wan2,wan3>>> by PCC divide traffic
input ip :1.1.1.5 , 1.1.2.5 , 1.1.3.5
output :local >>> 10.1.1.10
note:..
- every my Clint created by user-manager
- I not used bandwidth control by user-profile
can you help me ?
Thanks
Dear , i want mikro tik (RB1100HX2) hotspot configuration ,anyone can u give online support -
ReplyDeleteMr.Ketut Agus Suardika please give your contacting number
harisbabu75@gmail.com
I don't found parent-Global Out/Global in on queue tree menu. Please help me. What i am doing now?
ReplyDeletepak Ketut Agus Suardika spesifikasi utk router yang di gunakan utk setingan di atas menggunakan RB berapa minimalnya, soalnya sy pakai RB 751 U utk peroses awal setingan berjalan dgn baik tp beberapa lama kemudian di log nya slalu ada keterangan ETHER 2,(LOKAL) ETHER 4 HOTSPOT DAN ETHER 5 GATEWAY INTERNET ada keterangan Link Down beberapa detik kemudian UP lagi, dan itu berkelanjutan, apakah spek RB yg sy gunakan tdk mumpuni, trima kasih.
ReplyDeleteI am using Mikrotik RB411Ah (v5.5) as Access Point bridge for point to multipoint wireless connections.
ReplyDeletehttp://j33x.com
http://www.jeux44.com
http://www.banatmix.com
j33x
العاب طوب
اضغط هنا
هناااا
انقر هنا
hi can you upload the script
ReplyDeletemo tanya bisa diterapkan di sistem DCHP tidak? sorry masih pemula
ReplyDeletepak Ketut Agus Suardika,,
ReplyDeletetolong masukan dan sarannya,,
saya mau bagi beberapa group IP dari 60 IP (acak dalam 1 group) dalam 1 network
anggap saja group 1 sd group 5
agar streaming (video), browsing, internet bangking pada masing2 group bisa di atur bandwidthnya, sebaiknya settinggan queue pakai apa dan bagaimana pak..?
mohon pencerahannya,,,tolong email jg ke agustri1301@gmail.com
Terima kasih banyak
setelah di coba ternyata mangle pada tiap" ip address tidak ada aktifitas sama sekali
ReplyDeleteyang hanya aktifitas mangle berikut saja
/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no in-interface=ether1 new-connection-mark=All-Inconn passthrough=yes comment="UPSTEAM CONNECTION"
add action=mark-packet chain=prerouting connection-mark=all-inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM"
add action=mark-connection chain=forward disabled=no in-interface=wlan1 new-connection-mark=All-Outconn passthrough=yes comment="DOWNSTEAM CONNECTION"
add action=mark-packet chain=forward connection-mark=all-outconn disabled=no new-packet-mark=All-Outpkt passthrough=yes comment="DOWNSTEAM"
mohon bantuan nya pak
If my network used dhcp to clients, can I use the same full bandwidth management parent queue instead of using static IP for my client ?
ReplyDeleteTerima kasih banyak pak Ketut sangat membantu sekali
ReplyDeleteada sedikit koreksi..atau mungkin saya yang salah
/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
di atas parentnya adalah global-out,tapi di mikrotik tidak ada interface itu..yang ada hanya global saja
maaf klo sekiranya saya salah
Hi, just saw your tutorial (https://www.youtube.com/watch?v=n4QZl_9pubo) and I am currently in a verge of setting up my mikrotik to its full potential. Otherwise I am currently using it as a Hotspot server and currently using Usermanager as bandwidth limiter. Just wanted to know if these tutorial of yours can do manage hotspot with usermanager also and apply those settings even i have indicated a limited bandwidth using usermanager? I am interested in your tutorial since it is gradually and specifically looking traffic and separating them in a way to maximize connection. Please do contact me here or please do reply to my email(rolly_bacanto_jr@yahoo.com) whenever you read this, Terimakasi...
ReplyDeleteCool...jaringan jadi stabil, dan akses ke berbagai situs jadi lancar.
ReplyDeletei have 10 Mbps 1:1 , i want to distribute 2 Mbps each ( to 10 clients) and 4 Mbps (to 10 clients) and 4 Mbps for me (1:1).
ReplyDeletenow suggest me policies and script on Mikrotik
apakah ada tutorial yang mengkolaborasikan mangle + queue tree dan PCQ ,?
ReplyDeletekalau ada minta linknya
mas apakah itu tiap client nya di queue tree pake IP? atau gimana, bisa di jelaskan mas
ReplyDeleteThis comment has been removed by the author.
ReplyDeletethis is crap
ReplyDeletemost important to manage is the upload speed
this script will make worst on online games
ex. client 2 client 4 and client 5 playing dota 2
when client 1 uploading videos or pics
all of client that playing dota 2 will experience a very high ping
this blog is shit
trimakasih min..
ReplyDeleteini bisa semua router os? atau hanya di 6.30?
ijin copi scrip nya , semoga berhasil....
sore min... udah saya copi ke rb450g os 6.35.2
ReplyDeleteurutanya modem>>>ether1 wlan>>>>switchhub/ pc warnet.
ip modem 192.168.8.1 to ether1 ip 192.168.8.2/24
ip wlan1 192.168.1.0/24
scrip ini ga bisa kenapayah?
/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
saya edit seperti ini
/queue tree
add name=All-Bandwidth parent=global packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
baru bisa
dan semua queue tree ga aktif / ga bisa jalan
pada ip firewall mangle scrip ada yg kurang, jumlah item cuma 60, pada foto mimin ada 68 item,
tolong bantuanya... min..
biar bisa work..
trimakasih maaf jika ada yg salah :)
selamat malam, saya mau tanya bagaimana cara membatasi download melalui www.wetransfer.com karena selama saya menggunakan setting yg kak ketut Agus berikan sangat baik menurut saya dan sangat membantu diwarnet saya namun kendala terjadi ketika ada user transfer file sampai 2Gb sehingga sangat mengganggu pengguna game online meohon petunjuknya karena sangat tidak nyaman ketiga pemain game menjadi sangat lag.... mohon bantuannya mengatasi masalah saya. saya menggunakan indihome 10Mb
ReplyDeletemalam mas ketut agus,... itu yg di namakan billing sama Master apa yah"..
ReplyDeleteklo WArnet sy kan 1=SERVER. 10=CLEAN ,... tolong Pencerahan'a,..
mas Ketut Agus.. makasih
saya masih bingung dengan scrip
ReplyDeleteadakah yang di masukkan ke "/system script" atau scrip yang di maksud itu mangle itu semua?? tolong pencerahannya mas agus ketut
kontribusi yang baik seperti jika saya bisa membuat lebih banyak garis WAN1, WAN1, WAN3
ReplyDeleteSejalan coomo serius ini
/ Ip mangle firewall
menambahkan action = mark-connection PREROUTING rantai = disabled = no di-interface = ether1 baru-connection-mark = All-Inconn passthrough = yes comment = "CONNECTION upsteam"
menambahkan action = mark-packet = PREROUTING rantai connection-mark = all-inconn disabled = no baru-packet-mark = All-inpkt passthrough = yes comment = "upsteam"
add chain action = mark-connection = maju disabled = no di-interface = wlan1 baru-connection-mark = All-Outconn passthrough = yes comment = "downsteam CONNECTION"
menambahkan action = mark-packet chain = maju connection-mark = all-outconn disabled = no baru-packet-mark = All-Outpkt passthrough = yes comment = "downsteam"
membantu saya silahkan dan lebih baris kode perlu mengubah.
script macet di parent =global out ?
ReplyDeleteglobal in
global out belum terdefinisi
yang ada global aja ...?
saya pake RB750 mohon pencerahannya
how to use this in new version v6XX.. thank you
ReplyDeletehi! 1mbps bandwidth can manage 4 pc for online games, browsing, downloading & streaming?
ReplyDelete
ReplyDeleteProbe and probe but nothing everything does not run anything when I generate traffic, I do not know what happens probe in many ways but I still do not walk these rules with mikrotik I think something is wrong here in this rules so it does not work that can help me or know by That does not run these rules in mikrotik I want to implement it as it is and I'm not helping, please
Lostsaga Port scanner result:
ReplyDeletetcp:9000,14009,14010,61031,61034,61035,61037,61046,61047,61048,61049,61051,61058
udp:14009,14010,14017,14019,14024,14025,14042,14113,14120,14245,14263,15494,21530,22317,22561,26019,30146,32629,45693
please cross check! new optimize bandwidth management will coming soon!
how i connect client1
ReplyDeletewhere i put client1 ip
kenapa tidak ada mangle uploadnya?
ReplyDeleteapakah saya kliru atau gimana??
bagaimana caranya jika saya memiliki sebuah proxy eksternal dan ingin menggunakan scrip diatas? apa yang mesti saya tambahkan pada pengaturan mikrotiknya pak? trims ....tolong pencerahannya
ReplyDeletecan you do this job more me , i can pay you , my skype : fadi.ajrab, please contat me
ReplyDeleteThank you Ketut for your excelent videos, i hope you can help me with this question about this metod, what happens if i have more than 1 plan?, example, i have users with 1Mb download and others with 2Mb download, i supposed if i don´t leak of bandwitch each user will get what he needs, but what happens with this metod if for example i have a parent with 2Mb total download and the user 1Mb and 2Mb try to use all his allowed bandwith, it will part equaly or the 2Mb user will get a little more? Thank you so much!
ReplyDeletebli
ReplyDeleteether1 sbg wan disini yg mana ya?
ditambahin script virus drop dan p2p (peer to peer)
Interface wan adalah interface dimana kabel yang berisi koneksi internet masuk ke router.
Delete/ip firewall filter
add action=jump chain=forward comment="Check for infected computers" jump-target=detect-virus
add action=drop chain=detect-virus comment="Drop Blaster Worm" dst-port=135-139 protocol=tcp
add action=drop chain=detect-virus comment="Drop Messenger Worm" dst-port=135-139 log-prefix="[ detect-virus ]" protocol=udp
add action=drop chain=detect-virus comment="Drop Blaster Worm" dst-port=445 protocol=tcp
add action=drop chain=detect-virus comment="Drop Blaster Worm" dst-port=445 protocol=udp
add action=drop chain=detect-virus comment=________ dst-port=593 protocol=tcp
add action=drop chain=detect-virus comment=________ dst-port=1024-1030 protocol=tcp
add action=drop chain=detect-virus comment="Drop MyDoom" dst-port=1080 protocol=tcp
add action=drop chain=detect-virus comment=________ dst-port=1214 protocol=tcp
add action=drop chain=detect-virus comment="ndm requester" dst-port=1363 protocol=tcp
add action=drop chain=detect-virus comment="ndm server" dst-port=1364 protocol=tcp
add action=drop chain=detect-virus comment="screen cast" dst-port=1368 protocol=tcp
add action=drop chain=detect-virus comment=hromgrafx dst-port=1373 protocol=tcp
add action=drop chain=detect-virus comment=cichlid dst-port=1377 protocol=tcp
add action=drop chain=detect-virus comment="Beagle detect-virus" dst-port=2745 protocol=tcp
add action=drop chain=detect-virus comment="Drop Dumaru.Y" dst-port=2283 protocol=tcp
add action=drop chain=detect-virus comment="Drop Beagle" dst-port=2535 protocol=tcp
add action=drop chain=detect-virus comment="Drop Beagle.C-K" dst-port=2745 protocol=tcp
add action=drop chain=detect-virus comment="Drop MyDoom" dst-port=3127-3128 protocol=tcp
add action=drop chain=detect-virus comment="Drop Backdoor OptixPro" dst-port=3410 protocol=tcp
add action=drop chain=detect-virus comment=Worm dst-port=4444 protocol=tcp
add action=drop chain=detect-virus comment=Worm dst-port=4444 protocol=udp
add action=drop chain=detect-virus comment="Drop Sasser" dst-port=5554 protocol=tcp
add action=drop chain=detect-virus comment="Drop Beagle.B" dst-port=8866 protocol=tcp
add action=drop chain=detect-virus comment="Drop Dabber.A-B" dst-port=9898 protocol=tcp
add action=drop chain=detect-virus comment="Drop Dumaru.Y" dst-port=10000 protocol=tcp
add action=drop chain=detect-virus comment="Drop MyDoom.B" dst-port=10080 protocol=tcp
add action=drop chain=detect-virus comment="Drop NetBus" dst-port=12345 protocol=tcp
add action=drop chain=detect-virus comment="Drop Kuang2" dst-port=17300 protocol=tcp
add action=drop chain=detect-virus comment="Drop SubSeven" dst-port=27374 protocol=tcp
add action=drop chain=detect-virus comment="Drop PhatBot, Agobot, Gaobot" dst-port=65506 protocol=tcp
saya ingin bertanya sekaligus mohon pencerahannya. maaf baru mengenal mikrotik
ReplyDeletetopologi sy sprt ini
isp----->RB----->hub----->client dengan isp indihome 50mbps, setting modemnya bridge (dial di RB).
ether1=isp
ether5=local
yang mana In-Interface ?
Out-Interface ?
apakah in-interface= ether5
Out-Interface : ether1 ataukah pake pppoe-nya
bagaimana pembagian BW jika di pakai di tempat saya dengan jumlah client 20?
bagaimana cara menentukan burst-limit, burst-threshold berdasarkan maksimal limit yang telah dipatok untuk masing2 client??
Mudah mudahan ini bisa menjadi referensi buat anda https://agratitudesign.blogspot.com/2017/07/setup-pppoe-connection-to-mikrotik.html
Deleteinterface gatewaynya bukan fisiknya(isp) lagi melainkan interface pada setup pppoe-client
Hi, I followed your settings and reviewed it multiple times. I just cant figure out why the Games part is not working properly. The only working parts are Browsing and Downloads. Does Game and Streaming really working on your end?
ReplyDeleteMany thanks!
is this format is fit to 10 client & 1 server?
ReplyDeleteVery helpful suggestions that help in the optimizing topic,Thanks for your sharing.
ReplyDeleteดูหนังออนไลน์
mas buat rb 450 g ada soal saya paste Queue Tree nya g muncul
ReplyDeleteMaaf kang agus, itu di atas hanya khusus untuk pengguna PC pada warnet saja kah?
ReplyDeleteBagaimana kalau untuk settingan wifi/hotspot nya?
soalnya saya pakainya untuk hotspot, jadi gak pakai PC (seperti RT/RW NET gitu)
keterangan:
- Ether1 = WAN
- Ether2 = LAN (menuju ke AP)
- Wirelles = WLAN1 ( Wifi bawaan Mikrotik )
Mikrotik yg saya pakai RB951-2n yang ada Wireless nya
kalau mesti input 1 per 1 menggunakan IP, berarti banyak donk ya yg harus di input manual ip nya..
keterangan:
- LAN = IP 192.168.90.1 s/d 254
- WLAN1 = 192.168.100.1 s/d 254
mohon bantuan nya kang Agus..
indobook.id@gmail.com
ReplyDeleteGood luck gambling.
IBCbet Online Gambling Games Site The game is getting more and more popular. Online Gambling Game The game is fun and fun. Every time you participate in online betting. Good luck gambling. The game is becoming more and more popular today, the casino is a game that many people are well acquainted. Easy access. The player can bet on the screen as well. Do not have to travel far. Many people are interested in no one to enter the casino every day. Today's Online Gambling I have more and more popular.
Choose the most played. People are the most common gambling. With 24-hour service, pay close attention to the latest trends. The way to happiness every day. Interested in winning more than 30 million prize money online activities around the world to pay attention. Welcome to every aspect of gambling. Play the game through a new dimension. Get rich every day Subscribe to gambling at the web Gclub Slot
Maaf mas Agus, saya mau bertanya. di dalam penjelasan video anda hanya terdapat 5 client saja, jika untuk menambahkan sejumlah client lagi saat copy paste scrip-nya apa hanya mengubah IP address-nya saja??.
ReplyDeleteContoh dalam 1 warnet terdapat 27 client. untuk setting nya IP hanya menambahkan saja gitu kan??
hi
ReplyDeletei have 2 line connection
- Ether1 = in1
- Ether2 = in2
and - Ether3 = out
i make it bridge
address ip 192.168.88.1/24
how to add 2 line in this script
many thanks
how to make bandwidth with 2 line bridge
Deleteif not mistaken, this tutorial is intended for wireless end-user. this scripts designs for offices. i think it is not suitable for those who want to apply it for businesses like internet cafe.
ReplyDeleteThis comment has been removed by the author.
Deletelet say i have 100 units with DHCP i don't think so if i will put all clients
Deletemas mau nanya mas
ReplyDeletesaya kan saya copy semua nya script punya mas ini dan sudah saya terapkan mas,
tapi saya ada kendala mas
di mana saat saya test gak ada yg bergerak atau jalan di queue tree nya mas
saya test pakai speed test dan gak ada terbatas bandwidth nya mas.
itu dimananya yang salah script nya ya mas??
mohon kasih solusi nya mas
this config work PUBG online game ?
ReplyDelete=
gan ada ngga rumus untuk menghitung bandwidth secara matematik
ReplyDeletekasus
bandwidth = 30 Mbps
jumlah user = 900 user
bagaimana menghitung bandwidth / client secara matematik
ada rumus nya ngga..?
/ip firewall mangle
ReplyDeleteadd action=mark-connection chain=prerouting disabled=no in-interface=ether1 new-connection-mark=All-Inconn passthrough=yes comment="UPSTEAM CONNECTION"
add action=mark-packet chain=prerouting connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM"
add action=mark-connection chain=forward disabled=no in-interface=wlan1 new-connection-mark=All-Outconn passthrough=yes comment="DOWNSTEAM CONNECTION"
add action=mark-packet chain=forward connection-mark=All-Outconn disabled=no new-packet-mark=All-Outpkt passthrough=yes comment="DOWNSTEAM"
dan karena mikrotiknya v6
/queue tree
add name=All-Bandwidth parent=global packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
Hello man, Can you send me the correct configuration you made ? because i am stuck at line 7
ReplyDelete/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=8 max-limit=2M
input does not match any value of parent
thank you!
even tho i am doing the steps exactly like you and i replaced my own IPs and i saw your mistake and replaced it
ReplyDeleteSuka bangeeet mau deh diaplikasikan di mikrotik ku
ReplyDeletebarang kali bisa sambil belajar hhehe
hi thx for this video . really it's great
ReplyDeletebut i have a question, i have 24 pc how can i change this scripts ?
bagaimana caranya script itu bisa berjaln dymanic sesuai dengan user yang terkoneksikejaringan
ReplyDeletePlease keep sharing more and more information about this.
ReplyDeleteเว็บย่อลิ้ง
เว็บย่อลิ้งค์
ย่อลิ้ง
ย่อurl
ย่อเว็บ
Put more information in like this blog, visit OGEN Infosystem (P) Ltd for responsive website design based on device view for your website by experienced website designers and also get SEO Services.
ReplyDeleteSEO Service in Delhi
Bli..
ReplyDeleteSaya membuat koneksi mikrotik dengan interface
Ether1-Isp
Bridge1_AP (ether2, ether3,..wlan1)
Pool lan 192.168.2.2-192.168.2.254
Koneksi internet 10Mbps.
Bagaimana setting terbaik agar game online android tidak ngelag saat yg lain nonton youtube dan download. Mohon pencerahanya, matursuwun
Nice thanks for sharing, Photo Booth for Sale
ReplyDeleteChSofts
ReplyDeleteFull version crack software is here
Excellent blog info thanks Providing Us With This Great Knowledge Free Mot History Check
ReplyDelete