Graphic Web Design, Computer Network, Balinese Culture

1 comment
Bandwidth Stabilizer Script for Mikrotik Router

Internet connection by the Internet service provider (ISP) which has many clients that tends to increase with time goes. The problem comes when the increased number of clients that they have not comparable with the services that they purchased from the first party. From the client side like me can not do anything with ISP services are diminishing because of the large number of their clients. Of course ISP will dodge with a lot of reasons if called has provides with bad services. On this situation it is hard to say which one the best ISP that can provide a good services.

Internet connection that slower than standard bandwidth speed of which we should get caused a lot of possibilities. Such as the quality of the wireless equipment used, technical installation of the wireless network, interference frequencies are used, overload client that the ISP have, and etc. So I don't say that this script will be able to overcome the slow internet connection absolutely. This script just only help to stabilize the connection upon congested traffic, the rest just the ISP that knowing.

Congested Traffic to be one of the causes of ping enlarge that make connection to be slow. We will harness the ability of Mikrotik in conditioning ping and finding a bus way during congested traffic so that the connection does not hang on. But the most common problem was caused by technical problem associated with the ISP related to the number of clients that they have.

OK we get started immediately for Bandwidth Stabilizer Script On Mikrotik Winbox by making mangle rule on the firewall and queue tree

1. Login to the Winbox with account that you have. Then click the New Terminal menu and enter the following script at the cursor terminal window. As shown like the picture below
/ip firewall mangle add chain=prerouting \
protocol=icmp action=mark-connection \
new-connection-mark=ICMP_CONNECTION \
passthrough=yes comment="ICMP_CONNECTION" \
Still in the terminal window, enter the second mangle firewall script below. Right-click at the cursor and paste therein. As shown like the picture below.
/ip firewall mangle add chain=prerouting \
protocol=icmp connection-mark=ICMP_CONNECTION \
action=mark-packet new-packet-mark=ICMP_PACKET \
passthrough=no comment="ICMP_PACKET" \

Then you can see the result on the firewall window at mangle tab. The both script that we enter to the terminal window above will create a rule on the firewall mangle on the Mikrotik. As shown like the picture below.

2. The Next we are going to create a queue tree rule. Click on the New terminal again and enter the following script by right click at the cursor on the terminal window and paste therein, as shown like the picture below.
/queue tree add name="==PING_CONDITION==" \
parent=global-total packet-mark=ICMP_PACKET \
limit-at=0 queue=default priority=1 max-limit=0 \
burst-limit=0 burst-threshold=0 burst-time=0s

At last we going to see the third script that we have inserted by click on queues>Queue Tree. It will look like at the right picture above. From my experience these script just only to stabilize the connection to avoid hang on when browsing during congested traffic usually at the daytime. If you are curious you can try this! Good Luck!
Share This Article :
Related Articles

1 comment :

    I got this error Please help me out