Graphic Motion Video Art, Website, IT Network, Culture

Loading...
Complete Queue Tree Per Clients Without Queue Simple Mikrotik
Complete Queue Tree Rules Without Queue Simple on Mikrotik is the evaluation of previous method about Bandwitdh management on mikrotik all is using queue tree rules. In this case I have completed with P2P and torrent sites queue tree rules that may used by the clients. In addition I have found a method to separate the upload packets completely from the kind of the other connection packets, that most used.  It will make the queue tree rules doesn’t require queue simple at all, because it has already covered all the connection packets.

This is the latest note which is a method of optimization that I applied as the result of the bandwidth management quality of system (QoS) evaluation on Mikrotik for more ideally. It still applied on the static IP PC clients as shown like the picture above, the hierarchy of queue tree rules per client. First I separate the connection packets between the bytes downloaded (downstreams) and bytes uploaded (upstreams). It should be emphasized here, for example when we are browsing, downloading etc are downstreams to be the most dominant bytes connection packets, and will take a small bytes of upstreams it relates to tx and rx bytes when we use the internet connection generally. Bytes upstream only dominant when you upload any kind of files. Actually bandwidth management is more focused on managing of connection packets of downstreams.

One more thing to be my note here, that is much easier if you want to drop the connection packets on the firewall filter rather than managing on the queue tree rules perfectly. This method contains with fix upload connection packets per client and the addition of p2p & Torrent sites Queue tree rules. Ok let's get started with the new emphasis of the two things.

1. Upload and Download Connection Packets per Client

I would give the following mangle rules to capture the connection packets upload (upstreams) and the connection packets for download (downstreams). The hierarchy of the queue tree rules will must be set with the parent global-in and global-out. The following scripts could be explicitly separating connection packets upload and download per client using different chain on mangle.

/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no in-interface=ether1 new-connection-mark=all-inconn passthrough=yes comment="CONNECTION-IN"
add action=mark-packet chain=prerouting connection-mark=all-inconn disabled=no new-packet-mark=all-inpkt passthrough=yes comment="UPLOAD"
add action=mark-connection chain=forward disabled=no out-interface=wlan1 new-connection-mark=all-outconn passthrough=yes comment="CONNECTION-OUT"
add action=mark-packet chain=forward connection-mark=all-outconn disabled=no new-packet-mark=all-outpkt passthrough=yes comment="DOWNLOAD"

/ip firewall mangle
add action=mark-packet chain=forward dst-address=192.168.1.11 packet-mark=all-outpkt new-packet-mark=billing-pktd passthrough=yes comment="BILLING DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.17 packet-mark=all-outpkt new-packet-mark=client1-pktd passthrough=yes comment="CLIENT1 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.16 packet-mark=all-outpkt new-packet-mark=client2-pktd passthrough=yes comment="CLIENT2 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.15 packet-mark=all-outpkt new-packet-mark=client3-pktd passthrough=yes comment="CLIENT3 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.14 packet-mark=all-outpkt new-packet-mark=client4-pktd passthrough=yes comment="CLIENT4 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.20 packet-mark=all-outpkt new-packet-mark=client5-pktd passthrough=yes comment="CLIENT5 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.21 packet-mark=all-outpkt new-packet-mark=client6-pktd passthrough=yes comment="CLIENT6 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.8 packet-mark=all-outpkt new-packet-mark=master-pktd passthrough=yes comment="MASTER DOWNSTREAM"

/ip firewall mangle
add action=mark-packet chain=prerouting src-address=192.168.1.11 packet-mark=all-inpkt new-packet-mark=billing-pktp passthrough=no comment="BILLING UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.17 packet-mark=all-inpkt new-packet-mark=client1-pktp passthrough=no comment="CLIENT1 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.16 packet-mark=all-inpkt new-packet-mark=client2-pktp passthrough=no comment="CLIENT2 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.15 packet-mark=all-inpkt new-packet-mark=client3-pktp passthrough=no comment="CLIENT3 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.14 packet-mark=all-inpkt new-packet-mark=client4-pktp passthrough=no comment="CLIENT4 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.20 packet-mark=all-inpkt new-packet-mark=client5-pktp passthrough=no comment="CLIENT5 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.21 packet-mark=all-inpkt new-packet-mark=client6-pktp passthrough=no comment="CLIENT6 UPSTREAM"
add action=mark-packet chain=prerouting src-address=192.168.1.8 packet-mark=all-inpkt new-packet-mark=master-pkt passthrough=no comment="MASTER UPSTREAM"

Notation for the script above, to capture the bytes download (dowstreams) using chain=forward and bytes upload (upstreams) using chain=prerouting. You can see the packet flow should be understood with the following scheme!


The separation of the connection packets based on the above scripts I have not found the leakage of the connection packets of the mangle rules again. All connection packets already covered at all. And then you just need to separate the bytes connection packets downstreams that most commonly used and give prioritize and limit speed from that.

2. Complete Mangle Rules with P2P and Torrent Sites Marking

This is containing the connection packets which is most clients use and spend a lot of bandwidth. Personally I don't like the clients to use this kind connection packet. But to prevent the bandwidth just used by this connection packets, therefore I will prioritize it to the last priority. first, create the mangle rules as the scripts below!

/ip firewall layer7-protocol
add name=bittorrent regexp="^(\13bittorrent protocol|azver1\$|get /scrape\\\\?info_hash=)|d1:ad2:id20:|8’7P\\)[RP]"
add name=torrentsites regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$" 

/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=billing-tpkt packet-mark=billing-pktd passthrough=no comment="BILLING BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=billing-tpkt packet-mark=billing-pktd passthrough=no comment="BILLING TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=billing-tpkt packet-mark=billing-pktd passthrough=no comment="BILLING ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=billing-tpkt packet-mark=billing-pktd passthrough=no protocol=tcp comment="BILLING TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client1-tpkt packet-mark=client1-pktd passthrough=no comment="CLIENT1 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client1-tpkt packet-mark=client1-pktd passthrough=no comment="CLIENT1 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client1-tpkt packet-mark=client1-pktd passthrough=no comment="CLIENT1 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client1-tpkt packet-mark=client1-pktd passthrough=no protocol=tcp comment="CLIENT1 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client2-tpkt packet-mark=client2-pktd passthrough=no comment="CLIENT2 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client2-tpkt packet-mark=client2-pktd passthrough=no comment="CLIENT2 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client2-tpkt packet-mark=client2-pktd passthrough=no comment="CLIENT2 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client2-tpkt packet-mark=client2-pktd passthrough=no protocol=tcp comment="CLIENT2 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client3-tpkt packet-mark=client3-pktd passthrough=no comment="CLIENT3 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client3-tpkt packet-mark=client3-pktd passthrough=no comment="CLIENT3 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client3-tpkt packet-mark=client3-pktd passthrough=no comment="CLIENT3 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client3-tpkt packet-mark=client3-pktd passthrough=no protocol=tcp comment="CLIENT3 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client4-tpkt packet-mark=client4-pktd passthrough=no comment="CLIENT4 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client4-tpkt packet-mark=client4-pktd passthrough=no comment="CLIENT4 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client4-tpkt packet-mark=client4-pktd passthrough=no comment="CLIENT4 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client4-tpkt packet-mark=client4-pktd passthrough=no protocol=tcp comment="CLIENT4 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client5-tpkt packet-mark=client5-pktd passthrough=no comment="CLIENT5 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client5-tpkt packet-mark=client5-pktd passthrough=no comment="CLIENT5 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client5-tpkt packet-mark=client5-pktd passthrough=no comment="CLIENT5 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client5-tpkt packet-mark=client5-pktd passthrough=no protocol=tcp comment="CLIENT5 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=client6-tpkt packet-mark=client6-pktd passthrough=no comment="CLIENT6 BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=client6-tpkt packet-mark=client6-pktd passthrough=no comment="CLIENT6 TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=client6-tpkt packet-mark=client6-pktd passthrough=no comment="CLIENT6 ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=client6-tpkt packet-mark=client6-pktd passthrough=no protocol=tcp comment="CLIENT6 TORRENT PORT"

add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=master-tpkt packet-mark=master-pktd passthrough=no comment="MASTER BIT TORRENT"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mark=master-tpkt packet-mark=master-pktd passthrough=no comment="MASTER TORRENT WEBSITES"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=master-tpkt packet-mark=master-pktd passthrough=no comment="MASTER ALLP2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,59097 new-packet-mark=master-tpkt packet-mark=master-pktd passthrough=no protocol=tcp comment="MASTER TORRENT PORT"

You can see the unification of connection packets p2p and torrent sites per client above. Perhaps if you want to differentiate into another connection packets such a skype connection packets. It will be the same way. You must define or create the regexp on layer 7 protocols, before we can capture the connection packets on mangle. so the concept is the same!

The rest is completing with another mangle rules that I have given earlier in the perfection parents queue tree! Well, I just paste here for more clearly and not make confuse you, the mangle rules and the complete queue tree rules that no need using simple queue again.

/ip firewall layer7-protocol
add comment="download" name=high regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|0[0-9][1-9]|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
add comment="download" name=document regexp="^.*get.+\\.(pdf|doc|docx|xlsx|xls|rtf|ppt|ppt).*\$"
add comment="video" name=youtube regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$"
add comment="video" name=streaming regexp="videoplayback|video"

/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=billing-dpkt packet-mark=billing-pktd passthrough=no comment="BILLING DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=billing-dpkt packet-mark=billing-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=billing-dpkt packet-mark=billing-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client1-dpkt packet-mark=client1-pktd passthrough=no comment="CLIENT1 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client1-dpkt packet-mark=client1-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client1-dpkt packet-mark=client1-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client2-dpkt packet-mark=client2-pktd passthrough=no comment="CLIENT2 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client2-dpkt packet-mark=client2-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client2-dpkt packet-mark=client2-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client3-dpkt packet-mark=client3-pktd passthrough=no comment="CLIENT3 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client3-dpkt packet-mark=client3-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client3-dpkt packet-mark=client3-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client4-dpkt packet-mark=client4-pktd passthrough=no comment="CLIENT4 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client4-dpkt packet-mark=client4-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client4-dpkt packet-mark=client4-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client5-dpkt packet-mark=client5-pktd passthrough=no comment="CLIENT5 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client5-dpkt packet-mark=client5-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client5-dpkt packet-mark=client5-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=client6-dpkt packet-mark=client6-pktd passthrough=no comment="CLIENT6 DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=client6-dpkt packet-mark=client6-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client6-dpkt packet-mark=client6-pktd protocol=tcp comment=""
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=master-dpkt packet-mark=master-pktd passthrough=no comment="MASTER DOWNLOAD"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=master-dpkt packet-mark=master-pktd passthrough=no comment=""
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=master-dpkt packet-mark=master-pktd protocol=tcp comment=""

/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=billing-spkt packet-mark=billing-pktd passthrough=no comment="BILLING VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=billing-spkt packet-mark=billing-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client1-spkt packet-mark=client1-pktd passthrough=no comment="CLIENT1 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client1-spkt packet-mark=client1-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client2-spkt packet-mark=client2-pktd passthrough=no comment="CLIENT2 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client2-spkt packet-mark=client2-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client3-spkt packet-mark=client3-pktd passthrough=no comment="CLIENT3 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client3-spkt packet-mark=client3-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client4-spkt packet-mark=client4-pktd passthrough=no comment="CLIENT4 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client4-spkt packet-mark=client4-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client5-spkt packet-mark=client5-pktd passthrough=no comment="CLIENT5 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client5-spkt packet-mark=client5-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=client6-spkt packet-mark=client6-pktd passthrough=no comment="CLIENT6 VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=client6-spkt packet-mark=client6-pktd passthrough=no comment=""
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=master-spkt packet-mark=master-pktd passthrough=no comment="MASTER VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=master-spkt packet-mark=master-pktd passthrough=no comment=""

/ip firewall mangle
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=all-gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080

/ip firewall mangle
add action=mark-packet chain=forward src-address=192.168.1.11 packet-mark=all-gpkt new-packet-mark=billing-gpkt passthrough=no comment="BILLING GAMES"
add action=mark-packet chain=forward src-address=192.168.1.17 packet-mark=all-gpkt new-packet-mark=client1-gpkt passthrough=no comment="CLIENT1 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.16 packet-mark=all-gpkt new-packet-mark=client2-gpkt passthrough=no comment="CLIENT2 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.15 packet-mark=all-gpkt new-packet-mark=client3-gpkt passthrough=no comment="CLIENT3 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.14 packet-mark=all-gpkt new-packet-mark=client4-gpkt passthrough=no comment="CLIENT4 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.20 packet-mark=all-gpkt new-packet-mark=client5-gpkt passthrough=no comment="CLIENT5 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.21 packet-mark=all-gpkt new-packet-mark=client6-gpkt passthrough=no comment="CLIENT6 GAMES"
add action=mark-packet chain=forward src-address=192.168.1.8 packet-mark=all-gpkt new-packet-mark=master-gpkt passthrough=no comment="MASTER GAMES"

/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=billing-bpkt packet-mark=billing-pktd protocol=tcp comment="BILLING BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client1-bpkt packet-mark=client1-pktd protocol=tcp comment="CLIENT1 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client2-bpkt packet-mark=client2-pktd protocol=tcp comment="CLIENT2 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client3-bpkt packet-mark=client3-pktd protocol=tcp comment="CLIENT3 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client4-bpkt packet-mark=client4-pktd protocol=tcp comment="CLIENT4 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client5-bpkt packet-mark=client5-pktd protocol=tcp comment="CLIENT5 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=client6-bpkt packet-mark=client6-pktd protocol=tcp comment="CLIENT6 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no new-packet-mark=master-bpkt packet-mark=master-pktd protocol=tcp comment="MASTER BROWSING"

Next is how I set up and optimize the connection packets to make the hierarchy of queue tree rules per client completely.

/queue tree
add name=Billing-a.Upstreams parent=global-in packet-mark=billing-pktp queue=default priority=3 max-limit=256k
add name=Client1-a.Upstreams parent=global-in packet-mark=client1-pktp queue=default priority=3 max-limit=256k
add name=Client2-a.Upstreams parent=global-in packet-mark=client2-pktp queue=default priority=3 max-limit=256k
add name=Client3-a.Upstreams parent=global-in packet-mark=client3-pktp queue=default priority=3 max-limit=256k
add name=Client4-a.Upstreams parent=global-in packet-mark=client4-pktp queue=default priority=3 max-limit=256k
add name=Client5-a.Upstreams parent=global-in packet-mark=client5-pktp queue=default priority=3 max-limit=256k
add name=Client6-a.Upstreams parent=global-in packet-mark=client6-pktp queue=default priority=3 max-limit=256k
add name=Master-a.Upstreams parent=global-in packet-mark=master-pktp queue=default priority=3 max-limit=256k

/queue tree
add name=Billing-b.Downstreams parent=global-out packet-mark=billing-pktd queue=default priority=8 max-limit=256k
add name=Client1-b.Downstreams parent=global-out packet-mark=client1-pktd queue=default priority=8 max-limit=256k
add name=Client2-b.Downstreams parent=global-out packet-mark=client2-pktd queue=default priority=8 max-limit=256k
add name=Client3-b.Downstreams parent=global-out packet-mark=client3-pktd queue=default priority=8 max-limit=256k
add name=Client4-b.Downstreams parent=global-out packet-mark=client4-pktd queue=default priority=8 max-limit=256k
add name=Client5-b.Downstreams parent=global-out packet-mark=client5-pktd queue=default priority=8 max-limit=256k
add name=Client6-b.Downstreams parent=global-out packet-mark=client6-pktd queue=default priority=8 max-limit=256k
add name=Master-b.Downstreams parent=global-out packet-mark=master-pktd queue=default priority=8 max-limit=256k

/queue tree
add name=1.Billing-Games parent=Billing-b.Downstreams packet-mark=billing-gpkt queue=default priority=1 max-limit=256k
add name=1.Client1-Games parent=Client1-b.Downstreams packet-mark=client1-gpkt queue=default priority=1 max-limit=256k
add name=1.Client2-Games parent=Client2-b.Downstreams packet-mark=client2-gpkt queue=default priority=1 max-limit=256k
add name=1.Client3-Games parent=Client3-b.Downstreams packet-mark=client3-gpkt queue=default priority=1 max-limit=256k
add name=1.Client4-Games parent=Client4-b.Downstreams packet-mark=client4-gpkt queue=default priority=1 max-limit=256k
add name=1.Client5-Games parent=Client5-b.Downstreams packet-mark=client5-gpkt queue=default priority=1 max-limit=256k
add name=1.Client6-Games parent=Client6-b.Downstreams packet-mark=client6-gpkt queue=default priority=1 max-limit=256k
add name=1.Master-Games parent=Master-b.Downstreams packet-mark=master-gpkt queue=default priority=1 max-limit=256k

/queue tree
add name=2.Billing-Browsing parent=Billing-b.Downstreams packet-mark=billing-bpkt queue=default priority=2 max-limit=256k
add name=2.Client1-Browsing parent=Client1-b.Downstreams packet-mark=client1-bpkt queue=default priority=2 max-limit=256k
add name=2.Client2-Browsing parent=Client2-b.Downstreams packet-mark=client2-bpkt queue=default priority=2 max-limit=256k
add name=2.Client3-Browsing parent=Client3-b.Downstreams packet-mark=client3-bpkt queue=default priority=2 max-limit=256k
add name=2.Client4-Browsing parent=Client4-b.Downstreams packet-mark=client4-bpkt queue=default priority=2 max-limit=256k
add name=2.Client5-Browsing parent=Client5-b.Downstreams packet-mark=client5-bpkt queue=default priority=2 max-limit=256k
add name=2.Client6-Browsing parent=Client6-b.Downstreams packet-mark=client6-bpkt queue=default priority=2 max-limit=256k
add name=2.Master-Browsing parent=Master-b.Downstreams packet-mark=master-bpkt queue=default priority=2 max-limit=256k

/queue tree
add name=3.Billing-Download parent=Billing-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client1-Download parent=Client1-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client2-Download parent=Client2-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client3-Download parent=Client3-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client4-Download parent=Client4-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client5-Download parent=Client5-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Client6-Download parent=Client6-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k
add name=3.Master-Download parent=Master-b.Downstreams packet-mark=no-mark queue=default priority=4 max-limit=220k

/queue tree
add name=3.1.Billing-Undefined parent=3.Billing-Download packet-mark=billing-pktd queue=default priority=5
add name=3.1.Client1-Undefined parent=3.Client1-Download packet-mark=client1-pktd queue=default priority=5
add name=3.1.Client2-Undefined parent=3.Client2-Download packet-mark=client2-pktd queue=default priority=5
add name=3.1.Client3-Undefined parent=3.Client3-Download packet-mark=client3-pktd queue=default priority=5
add name=3.1.Client4-Undefined parent=3.Client4-Download packet-mark=client4-pktd queue=default priority=5
add name=3.1.Client5-Undefined parent=3.Client5-Download packet-mark=client5-pktd queue=default priority=5
add name=3.1.Client6-Undefined parent=3.Client6-Download packet-mark=client6-pktd queue=default priority=5
add name=3.1.Master-Undefined parent=3.Master-Download packet-mark=master-pktd queue=default priority=5

/queue tree
add name=3.2.Billing-Extensions parent=3.Billing-Download packet-mark=billing-dpkt queue=default priority=6
add name=3.2.Client1-Extensions parent=3.Client1-Download packet-mark=client1-dpkt queue=default priority=6
add name=3.2.Client2-Extensions parent=3.Client2-Download packet-mark=client2-dpkt queue=default priority=6
add name=3.2.Client3-Extensions parent=3.Client3-Download packet-mark=client3-dpkt queue=default priority=6
add name=3.2.Client4-Extensions parent=3.Client4-Download packet-mark=client4-dpkt queue=default priority=6
add name=3.2.Client5-Extensions parent=3.Client5-Download packet-mark=client5-dpkt queue=default priority=6
add name=3.2.Client6-Extensions parent=3.Client6-Download packet-mark=client6-dpkt queue=default priority=6
add name=3.2.Master-Extensions parent=3.Master-Download packet-mark=master-dpkt queue=default priority=6

/queue tree
add name=3.3.Billing-Video parent=3.Billing-Download packet-mark=billing-spkt queue=default priority=7
add name=3.3.Client1-Video parent=3.Client1-Download packet-mark=client1-spkt queue=default priority=7
add name=3.3.Client2-Video parent=3.Client2-Download packet-mark=client2-spkt queue=default priority=7
add name=3.3.Client3-Video parent=3.Client3-Download packet-mark=client3-spkt queue=default priority=7
add name=3.3.Client4-Video parent=3.Client4-Download packet-mark=client4-spkt queue=default priority=7
add name=3.3.Client5-Video parent=3.Client5-Download packet-mark=client5-spkt queue=default priority=7
add name=3.3.Client6-Video parent=3.Client6-Download packet-mark=client6-spkt queue=default priority=7
add name=3.3.Master-Video parent=3.Master-Download packet-mark=master-spkt queue=default priority=7

/queue tree
add name=3.4.Billing-TorP2P parent=3.Billing-Download packet-mark=billing-tpkt queue=default priority=8
add name=3.4.Client1-TorP2P parent=3.Client1-Download packet-mark=client1-tpkt queue=default priority=8
add name=3.4.Client2-TorP2P parent=3.Client2-Download packet-mark=client2-tpkt queue=default priority=8
add name=3.4.Client3-TorP2P parent=3.Client3-Download packet-mark=client3-tpkt queue=default priority=8
add name=3.4.Client4-TorP2P parent=3.Client4-Download packet-mark=client4-tpkt queue=default priority=8
add name=3.4.Client5-TorP2P parent=3.Client5-Download packet-mark=client5-tpkt queue=default priority=8
add name=3.4.Client6-TorP2P parent=3.Client6-Download packet-mark=client6-tpkt queue=default priority=8
add name=3.4.Master-TorP2P parent=3.Master-Download packet-mark=master-tpkt queue=default priority=8


The result you can see on the picture above. In order to get a balanced internet connection on each client, we could not only provide a greater speed limit on connection bytes downstreams of the particular packets while you press connection packets upload (upstreams). If you do that the internet connection will be unbalanced. It is closely related to the tx and rx bytes when we use any connection packets at all. Well, I think is enough to make the complete queue tree rules that no need simple queue again.

Share This Article :
Related Articles

154 comments :

  1. Replies
    1. Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download Now

      >>>>> Download Full

      Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download LINK

      >>>>> Download Now

      Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download Full

      >>>>> Download LINK lH

      Delete
  2. Terima kasih banyak Mas, sudah sukses saya terapin di warnet saya dengan bandwith 512k/4m. Cuma, saya mau tanya ne mas,, karena ud ga pake simple queue lagi, masih bisa kah kita terapkan burst limit dan burst treshold pada queue tree seperti ini,
    *Maap klo bahasa agak berbelit, thanks

    ReplyDelete
    Replies
    1. Saya kira gak ada masalah mas, tambahkan saja jika dirasa perlu!

      Delete
    2. owh,,,
      satu lagi mas,, baru nyadar tadi,
      /ip firewall layer7-protocol
      add comment="download" name=high regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|0[0-9][1-9]|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"

      add comment="download" name=document regexp="^.*get.+\\.(pdf|doc|docx|xlsx|xls|rtf|ppt|ppt).*\$"

      add comment="video" name=youtube regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$"

      add comment="video" name=streaming regexp="videoplayback|video"

      untuk layer7-protocol "bittorrent" dimana ya? rule magle P2P masih eror ne mas
      thaks

      Delete
    3. Oiya maaf ada yang ketinggalan, sudah saya lengkapi, terima kasih atas koreksinya mas!

      Delete
    4. Wah Download Jebol Gara2 Aktifin web Proxy,,,gmana ini,,,tp klo gak aktif web proxy nya setingan berjalan mulus,,
      bantu dong,,setingan mana yang mau ditambah biar jalan sam web proxy ny...

      Delete
  3. And what for version 6? Does the setting only changes to: global?
    global-in and global-out?

    ReplyDelete
    Replies
    1. The mangle must be use internal process of the router, using chain=input. But i can't prove it yet, i haven't version 6

      Delete
    2. Ketut, then in that case would have to add in mangle the input and output options. And Queues use "Global"? Thank you.

      Delete
  4. Hi,
    In the above and also in the perfection bandwidth management parent queue tree you showed in youtube i saw alot of client1 & billing and with this it comes to mind that you used the radius or user manager? can i use it without either radius or user manager? as i currently don't use either of them on my network as it is too small!
    i believe that this solution stops users from being too greedy with the available bandwidth right? please correct me if i am wrong. i await your response.
    Please if i can use it without radius and user manager and it will still be as effective please let me know how i will go about it!
    Thank you.

    ReplyDelete
  5. malam mas? jika di tambah eth3 untuk proxy server kira2 scrip yang cocok .gimana..mohon pencerahan?

    ReplyDelete
  6. Hi i am using pppoe connections with profile 1 and profile 2 ... profile 4. each profiles have different speed.
    so the question is how can i make your client 1 works with profile 1...etc

    please replay to me any thing

    ReplyDelete
  7. jika ini diterapkan di load balancing bisa ga ya? terus untuk out interface kita pake yang mana ?

    ReplyDelete
  8. version 6 change globan-in and global-out by global.

    Hey, thanks for share it.

    ReplyDelete
    Replies
    1. Well, change Global out and global in by LAN o WAN interfaces.

      Delete
  9. Excuse Me Dear Kindly Help Me Please ??

    ReplyDelete
  10. Dear Ketut Agus Suardika I Follow Your This Script Every Steps And Also Apply It On Our Mikrotik Machine That't Good But Many Quees Tree Its Not Work Proper Like Upstream Isn't Sent Or Receive Bytes 1st Tell Me That How Could I Correct It ..... ??

    ReplyDelete
  11. apa ada tutorialnya untuk pengguna hotspot aja mas bukan untuk warnet. kalau hotspot ya usernya kan ramai berbanding warnet. kalo ada tutorialnya yang complete gaya ini. mohon dibuatkan tutorialnya ya mas. maaf saya masih baru lagi dari malaysia

    ReplyDelete
  12. Mas Agus, Kalo settingan ini di tambah proxy eksternal ubuntu, gmana cara membuat manggle proxy HIT dan proxy MISS nya? Di tunggu mas pencerahan nya, Terima kasih Mas Agus sebelum nya.

    ReplyDelete
  13. mas agus, mohon bantuannya donk,. saya selalu gagal pada saat paste queue tree nya.. input does not gitu keluarnya.. mikrotik OS 5.20 dan 6. thx mas , mohon dibantu

    ReplyDelete
  14. cara melindungi qos dari serangan idm gimana gan.....

    ReplyDelete

  15. /ip firewall mangle
    add chain=prerouting in-interface=Local \
    dst-address=209.135.140.0/24 action=mark-packet \
    new-packet-mark=exempt-up
    add chain=postrouting out-interface=Local \
    src-address=209.135.140.0/24 action=mark-packet \
    new-packet-mark=exempt-down
    /queue type
    add name=exempt kind=sfq
    /queue tree
    add name=hotspot-exempt-up parent=global-in \
    packet-mark=exempt-up queue=exempt max-limit=1G
    add name=hotspot-exempt-down parent=global-out \
    packet-mark=exempt-down queue=exempt max-limit=1G

    This is a script to access a local server with 100Mb speed. This script works on os version 5.x. But On os version 6.x the script does not work as global in, global out option is replaced by global. Do you know how to solve this or have any other solution.

    ReplyDelete
  16. interface=ether1

    interface=wlan1

    ReplyDelete
    Replies
    1. ether1 itu ---> untuk public ?

      wlan itu LAN?


      yang public yang mana ya?

      Delete
  17. In limit the speed of an extension of the later mangle two minutes after work limit extension

    ReplyDelete
  18. is there no superposition b/w upload packets and download packets?
    cuz you defined and marked upload and download connections at the first of all

    ReplyDelete
    Replies
    1. Oh, if we mark packet secondly, new mark will overwrite!! solved my question

      Delete
  19. this is work dual wan load balancing with this scripts?
    please i need help

    ReplyDelete
  20. Replies
    1. why the queues tree script cant read or save.

      Delete
  21. how to make or add global-in and global-out my parent: global only thank you

    ReplyDelete
  22. is this possible for the mikrotik version 6 up?

    ReplyDelete
  23. Pertama" saya mau mengucapkan terima kasih buat Bpk Ketut telah membuatkan script yang baik dan work seperti ini. Saya sudah tes di v4.11 dan berjalan dengan baik, cuman permasalahan buat di upload saya coba test ke www.speedtest.net ko dia masih lolos ya pak?(bocor)

    Selebihnya udah mantap, kelimit semua dan jalan. Buat temen" yang belum work, coba dipahami dulu script nya satu persatu dibaca copy ke notepad, pasti work.

    ReplyDelete
  24. hi .. i just saw this blog about microtik for me you're a genius bcoz here in my country i must pay a large amount to configure this router so called mikrotik .. bro . may i know what kind of mikrotik router u had ?

    ReplyDelete
  25. E-mail with many attractive features and convenience are the choice of most people around the world open. And I want to share to everyone a free webmail services extremely great.
    outlook entrar , entrar no outlook , entrar outlook

    ReplyDelete
  26. hi... where do i find the parent GLOBAL-IN and GLOBAL-OUT? it's only global

    ReplyDelete
  27. i peering with google but i don't know how to configuration in microtik so please make video on this topic.....thanks

    ReplyDelete
  28. Upload not working...
    Anyone know how to fix it?

    ReplyDelete
  29. Victory coupled with online non-stop bets.
    คาสิโนออนไลน์ Online Gaming Channels It's a standard game that brings you access to easy-to-access and easy-to-use activities. This entertainment. Why wait for the open mind to play games with us, then know that making money shortcuts. It is another way to help you have more opportunities. Some people have many views. To look at Gambling Games Without Rich Days I do not have the money to tell you that the bet is not to rich people. It's up to the player himself, with luck, a lot of luck.

    Real money. People who do not have money is not able to play it, and most importantly, our site does not have any. Confident in our service. Good counsel Introduction to gambling games can be as easy as possible. Join the game through the communication device together. Fun online betting with us. Online Casino Games It is another option that many people are interested in and choose to bet online with us most often. In addition, gamers should bet on their own budget. Do not play beyond Or in the web site. คาสิโนออนไลน์

    ReplyDelete
  30. I Love your article. You cant visit my website : usphone book

    ReplyDelete
  31. buenas noche hermano esa reglas sirve para la version de mikrotik V5.20 porq soy nuevo en eso y quiero armar un servidor potente para mi red en venezuela

    ReplyDelete
  32. buenas noche hermano esa reglas sirve para la version de mikrotik V5.20 porq soy nuevo en eso y quiero armar un servidor potente para mi red en venezuela mi correo wordjoseartigas@gmail.com

    ReplyDelete
  33. An impressive share! I have just forwarded this onto a coworker who had been conducting a little homework on this. And he in fact bought me dinner due to the fact that I found it for him… lol. So allow me to reword this…. Thank YOU for the meal!! But yeah, thanx for spending time to discuss this topic here on your website. https://gbapps.net/yowhatsapp-apk-download/

    ReplyDelete
  34. ChSofts
    Full version crack software is here

    ReplyDelete
  35. ArchiCAD Torrent provides fresh structure groups, such as for instance IFC aspect kind and structural role, to better fit with the numerical units of offices.
    https://pcprosoft.com/archicad-crack/

    ReplyDelete
  36. need for speed shift 2 download
    Need For Speed Shift 2 Unleashed Pc Download: an action packed famous adventure Car Racing Pcc Game.

    ReplyDelete
  37. This comment has been removed by the author.

    ReplyDelete
  38. wow amazing one post about the Queue Tree Rules. thanks for helping us about this article.
    here is a app Farming Simulator APK. It is an amazing app that can make you a real farmer in the android device. The gameplay lets you make your farm in which you can grow crops by using different equipment.
    https://modsroid.com/farming-simulator-18-apk-obb-download-official-latest-version-2020

    ReplyDelete
  39. https://approvedcrack.com/iobit-uninstaller-pro-keys/
    IObit Uninstaller Pro Crack removes the file and folder. After deleting the file or program bit Uninstaller scans the computer and mobile phone. IObit Uninstaller Serial Key is also like a free app for computers and mobile phones. MostlyIObit Uninstallercannot work in window 10. Deeply clean every part of the computer and remove the all junk file of the computer. At least five version of IObit Uninstaller release and all this version perform different functionalities. And the latest version of IObit Uninstaller Torrent makes the computer in a comfortable form.

    ReplyDelete
  40. https://fullpcgameshere.com/
    Full pc games free Download Full Version is Here.

    ReplyDelete
  41. Moreover, fact single select in the button and untied down-load VCE Exam Simulator Crack. This device offers you a poor lot of large belief almost takes a look at training and practices.
    https://crackedpro.org/vce-exam-simulator-crack/

    ReplyDelete
  42. CleanMyMac X Keygen is basically a renowned application in your Apple ordinary surroundings, and that helps track the overall wellbeing of Macintosh systems.
    https://activatorpros.com/cleanmymac-x-crack-full-activation-number/

    ReplyDelete
  43. This comment has been removed by the author.

    ReplyDelete
  44. Movavi Video Editor 2020 Crack latest update comes up with a feature of drag and drop, cut, copy and paste, etc.
    https://shehrozpc.com/movavi-video-editor-crack/

    ReplyDelete
  45. WavePad Sound Editor Registration Key can edit the audio files and save them in different formats.
    https://letcracks.com/wavepad-sound-editor-crack/

    ReplyDelete
  46. DAEMON Tools Pro Keygen is among the greatest and advance programs.
    https://cracksmad.com/daemon-tools-pro-crack/

    ReplyDelete
  47. XLStat Torrent can input the data in Excel, and the display of results is done.
    https://chserialkey.com/xlstat-crack/

    ReplyDelete
  48. Mixcraft Pro Key can record an unlimited amount of audios and virtual instrumental tracks, crop, edit, add tons of effects and automation, crossfade sounds effortlessly.
    https://chproductkey.com/mixcraft-pro-crack/

    ReplyDelete
  49. Pycharm Keygen codes and syntax, it includes many grateful features. Moreover, a user is easily able to high light the errors as well.
    https://zscrack.com/pycharm-cracked/

    ReplyDelete
  50. Revo uninstaller Pro Crack is very flexible and easy to use. It also has professional technical support. It provides us many unique functions auto stare manger is one of them.
    https://zsactivationkey.com/revo-uninstaller-pro-crack/

    ReplyDelete
  51. VueScan Pro Keygen is also with the managing panel tabbed for input, crop, filter, colour, output, and prefs.
    https://ziapc.org/vuescan-pro-crack/

    ReplyDelete
  52. VueScan Pro Keygen is also with the managing panel tabbed for input, crop, filter, colour, output, and prefs. https://gbwhatsappapkmods.com/download-whatsapp-plus/ now her

    ReplyDelete
  53. XLStat Torrent can input the data in Excel, and the display of results is done. https://www.gbwhatsappr.com/whatsapp-plus-download/ is available now for download

    ReplyDelete
  54. Thanks for sharing Shala Darpan with us, guys! You are doing a great thing!

    ReplyDelete
  55. I'm happy to see the considerable subtle element here!.gb whatsapp download for iphone

    ReplyDelete
  56. Thank you so much for sharing with us. FMWhatsapp

    ReplyDelete
  57. The material and aggregation is excellent and telltale as comfortably.

    plugin manager notepad++

    ReplyDelete
  58. The blog and data is excellent and informative as well

    rice purity test average

    ReplyDelete
  59. Really impressed! Everything is very open and very clear clarification of issues. It contains truly facts. Your website is very valuable. Thanks for sharing.

    Popcorn Time Apk or Kinemaster Apk is a great apk for Android they works android without using Anonytun Pro Apk

    ReplyDelete
  60. Crack software!
    Here at Crackzoom you will get all your favorite software. Our site has a collection of useful software. That will help for your, Visite here and get all your favorite and useful software free.
    here Nice Article

    ReplyDelete
  61. An outstanding share! I've just forwarded this onto a friend who has been doing a little homework on this. And he in fact ordered me dinner simply because I found it for him... lol. So let me reword this.... Thanks for the meal!! But yeah, thanx for spending time to talk about this matter here on your web site.
    GBWhatsApp

    ReplyDelete
  62. After checking out a few of the articles on your blog, I truly appreciate your way of blogging. I saved as a favorite it to my bookmark webpage list and will be checking back in the near future. Please visit my website too and tell me your opinion.
    ZoozMobile

    ReplyDelete
  63. 123movies. to send messages, images, audio, or

    ReplyDelete
  64. 123movies. Internet to send messages, images,

    ReplyDelete
  65. download kinemaster pro apk is a full-featured free video editing app for android users. It is very easy and simple to use. It has lots of powerful tools that help you to make a professionals video.

    ReplyDelete
  66. movies123 best delivery stork must scramble to fix the error by delivering the baby.

    ReplyDelete
  67. Great whats app must visit https://yo-whatsapp.com/yowhatsapp-2020-latest-apk-v-9-10-download-android/

    ReplyDelete
  68. Dallas Cowboys game Cowboys Football Game Live live stream free online. Cowboys Game Today How to watch Cowboys football live stream Cowboys Game Online Free & Find Dallas Cowboys schedule, news update.
    Cowboys Live Game

    ReplyDelete
  69. Always use medicine carefully because it may cause some side effects. So it is most important for an individual to first know about a full medicine before starting using it. So you would love if you want to know about

    methycobal 500mg

    ReplyDelete
  70. Download Latest Apps From TechyList Such as FMWhatsApp GbWhatsApp and much more

    ReplyDelete
  71. This is my first time visiting here. I found so much entertaining in your site, especially its discussion. From the tons of comments on your articles, I guess I'm not the only one who has plenty of time here! Keep up the good work. I was planning to write something like this on my website/blog.

    ReplyDelete
  72. Pharmacy is the clinical health science that links medical science with chemistry and it is charged with the discovery, production, disposal, safe and effective use, and control of medications and drugs.
    galvus met

    ReplyDelete
  73. Thanks for sharing the valuable information with us. Phonedone

    ReplyDelete
  74. This comment has been removed by the author.

    ReplyDelete
  75. Your source for fun, free mobile and PC download games. Thousands of free ... Download or play free online! ... Here is the Exact Arcade Version of Dig Dug!
    gta v torrent highly compressed

    ReplyDelete
  76. Hello, I truly enjoyed reading your post. I found your site from Bing. Will bookmark to return later. Thanks! Also read this article M Sand Dealers In Bangalore

    ReplyDelete
  77. The Epson printer is quite possibly the most notable printers that is broadly utilized for printing purposes. These printers are effectively accessible on the lookout and user can get them at a sensible cost. The highlights of these printers are likewise helpful and are easy to use so that individuals of all age group can utilize them without confronting any problem. epson printer not printing black On the other hand, there are times when the Epson printers make issues and individuals whined that the printer isn't printing dark. This specific issue of the Epson printer not printing dark tone has now gotten normal and for the most part happens in light of different reasons changing from issues in the printers and network issue.

    ReplyDelete
  78. Worked with cutting edge innovation and outrageous exactness, Brother Printers are known for their uncommon print quality and strength. Regardless of whether it is your home or office arrangement, wired or router printing, these printers convey remarkable outcomes. Albeit these printers are one of numerous people's driving decisions, circumstances emerge when you'd experience issues like Brother printer won’t print. Such an issue could be problematic, particularly when you need to print something earnestly. An absence of investigating information can wait on such issues and hamper your profitability.

    ReplyDelete
  79. Hey, I really like this blog and it was very helpful for me ALots of people enjoy with this thecatmouseapk

    ReplyDelete
  80. It is memory friendly, and there are a vast majority of features that you can enjoy by using this version of YOWhatsApp APK.

    ReplyDelete
  81. Dolby Atmos Crack is a technology that aims to bring dynamic sound to our ears. Think of it as a 3D audio system.
    Valhalla DSP Bundle Crack
    Elementor Crack
    CyberGhost Crack

    ReplyDelete
  82. On the off chance that you notice moderate printing execution from different applications just as Word, a printer driver issue is a possible reason. Detach the printer and uninstall it through Control Panel to clear the current records and settings for the unit, then, at that point download and run the most recent adaptation of the driver from the maker's site. Reattach the printer to reinstall the devices. This interaction applies the latest bug fixes from the producer, further develops equipment and programming similarity, and improves the printer arrangement. At the point when moderate network printing inside an association is examined, the most well-known conversations and setup rotate around which equipment to change or programming setups to change. Yet, regularly, the justification for moderate printing isn't brought about by such shortcomings. why does my printer print so slow All things considered, it lies in the actual idea of how printers are arranged. Along these lines, it is normally hard to track down the genuine answers for the problems. The most normal way that printers are arranged is through print workers. Print workers can cause moderate printing since they are a solitary point through which all print occupations are being sent and handled. So if there are failures in this one point, the printing can get wasteful in the whole network.Sometimes when an association has numerous workplaces, the most financially savvy approach to organizing printers may be to have a focal print worker to which the printers in all workplaces are arranged. The issue, in any case, is that each time somebody prints, the print record will be sent over WAN to the worker and back, which can cause substantial network traffic and moderate printing for distant workplaces.

    ReplyDelete
  83. Its genuinely solid for you as displayed by an overall perspective all window programming foundation. This site is overpowering its article are major and gets. I appreciated and bookmark this site on my chrome. This is the place where you can get all window software for your pc and mac. This site help you in installing, keygen, patch, serial key, serial number, activation code and so forward
    https://letcracks.com/

    ReplyDelete
  84. Its truly strong for you as shown by a general viewpoint all window programming establishment. This site is overwhelming its article are major and gets. I appreciated and bookmark this site on my chrome. This is where you can get all window software for your pc and mac. This site help you in installing, keygen, patch, serial key, serial number, activation code and so forward
    https://cracksmad.com/

    ReplyDelete
  85. i was procastinating alot before but after using Forest mod apk i understood the value of timme.Thanks for making these site for us, Best Track Courier/a>

    ReplyDelete
  86. Nice blog keep it up please check out https://fmwafouad.com/ to use multiple accounts of whatsapp in one android device...

    ReplyDelete
  87. Download the YOWhatsApp latest version 2021 on your mobile phone and enjoy its features it.

    ReplyDelete
  88. Now with Thop TV you can watch the IPL matches. Thoptv IPL Live Match 2021 will let you support your favorite IPL team. IPL (Indian Premier League) is one of the most anticipated sports leagues this year. This cricket tournament is marked as a festival in India.

    ReplyDelete
  89. vst crack is available on PC just as it also for Windows and Windows.








    ReplyDelete
  90. I think you made awesome decision the moment when you choose this topic of the blog article here. Very useful information Netflix Crack Serial Key

    ReplyDelete
  91. thanks for sharing this impressive post.you can complete queue tree without queue tree simple mikrotik by using method that i share with you on Gb whatsapp APK

    ReplyDelete
  92. The information you have shared here is very helpful. I really like and appreciate your work. Thanks again for it, keep us updated in future! Whatsapp Plus Apk is also good.

    ReplyDelete
  93. This comment has been removed by the author.

    ReplyDelete
  94. Thanks for sharing the valuable information.
    https://yowaapp.com/

    ReplyDelete
  95. This software is easy to use.I like this software.https://wellcrack.com/spotify-premium-crack/

    ReplyDelete
  96. VivaVideo Editor 2022 MOD latest update comes up with a feature of drag and drop, cut, copy and paste, etc.
    VivaVideo MOD APK

    ReplyDelete
  97. I read your blog every day and take away a lot of useful information. keep it up. you can free download it: https://freesoftwareapps.com/indiafont-crack-free-download/

    ReplyDelete
  98. Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download Now

    >>>>> Download Full

    Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download LINK

    >>>>> Download Now

    Complete Queue Tree Without Queue Simple Mikrotik >>>>> Download Full

    >>>>> Download LINK

    ReplyDelete
  99. I am very impressed with your post because this post is very beneficial for me and provide a new knowledge to me
    Keep up the good work. And Thanks For Sharing

    K7 Total Security Crack

    Adobe Media Encoder Crack

    Adobe Photoshop CC Crack

    IObit Uninstaller Pro Crack

    DJ Music Mixer Pro Crack

    ReplyDelete
  100. Thanks for sharing this post. Your work is amazing. You can also check out PicPick Professional Crack for Free. You can also visit the Website vcracks.com
    PhpStorm Crack
    Camtasia Studio Crack

    ReplyDelete
  101. Thank you very much for sharing this wonderful essay. This is quite beneficial to me at work. https://crackspick.com/prodad-vitascene-crack-latest/

    ReplyDelete
  102. Crack Keygen Patch Softwares is the best place to download PC software, free and with serial key, Keygen, Crack and full version, also download android games and latest android applications. We update our site daily with the latest version. We provide direct download links for all software.

    ReplyDelete
  103. drawingstudios.com Free Games and Programs, you can download for free, a lot popular games with MOD for Android.

    ReplyDelete
  104. This comment has been removed by the author.

    ReplyDelete
  105. https://2023whatsapp.blogspot.com/2023/01/ogwhatsapp-pro-apk-2023-download.html

    ReplyDelete
  106. Desi Serial Sasural Simar Ka 2 is an Indian Hindi-language Supernatural television series that premiered on 26 April 2021 on Colors TV. It is a spiritual sequel to the

    ReplyDelete
  107. Download and watch indian and koren drama
    serial4

    ReplyDelete
  108. Katha Ankahee watch online latest episodes, Desi Serial Katha Ankahee Watch Online full aaj ka episode all hd videos Sony Liv, Katha Ankahee today episode, next episode

    ReplyDelete
  109. Interior Design is the art and science of enhancing the interior of a space to achieve a more aesthetically pleasing and functional environment for the people using it. It involves selecting and arranging decorative elements such as color schemes, furniture, lighting, and accessories, while also considering the layout, functionality, and safety of the space. Interior design can be applied to any type of space, from residential homes to commercial buildings, and can involve both new construction and renovations.

    ReplyDelete
  110. This comment has been removed by the author.

    ReplyDelete
  111. androidhub is best site get informations about android apps
    androidhub

    ReplyDelete
  112. sketchiz "Transforming spaces into captivating havens, our interior fit-out company specializes in crafting tailored solutions for commercial and residential projects. With an unwavering commitment to quality, innovation, and meticulous attention to detail, we bring dreams to life by seamlessly blending functionality and aesthetics. Welcome to a world of inspiring interiors."

    ReplyDelete
  113. It provides users with a distinctive and tailored Yo WhatsApp APK experience along with more freedom and control over their settings and conversations.

    ReplyDelete
  114. This comment has been removed by the author.

    ReplyDelete
  115. This comment has been removed by the author.

    ReplyDelete
  116. This comment has been removed by the author.

    ReplyDelete
  117. This comment has been removed by the author.

    ReplyDelete
  118. This comment has been removed by the author.

    ReplyDelete
  119. This comment has been removed by the author.

    ReplyDelete

Back to Top