Graphic Web Design, Computer Network, Balinese Culture

Build Hotspot Server with Web Login Pages of the User Profiles
This is the second part of the building hotspot network, I hope you've been following the previous articles, for the make you easy to understand of this term and conditions. I have explained the scheme and configuration and building the hotspot network before by using DHCP server, all clients can use the internet from the hotspot network to with the same username and password because just using single login from the wireless access point, this is not using the Hotspot Server and User Profiles to manage the hotspot network login.

This structure of the network system that I use ise the same as before, but in this case I did not use login from wireless TP-link as the access point. It will allows everyone to be able to access the web login page but to use the internet connection, client must login as the user hotspot server that we will build on the router. So wireless security of the access point will be disable as shown below!

First I remove the previous dhcp server with the IP Pool configuration, and also Firewall Filters and Nat to prevent the conflict with the hotspot server configuration that will also create a new dhcp server, IP pool, firewall filters and firewall nat automatically. You can also check the file list on the winbox should remove it because we will create as new hotspot files. While the mangle, layer 7 protocols and queue tree still you can use. So the basic configuration that should be remain as shown like the picture below!

1. Setup and configuration The Hotspot Server

If you have adjusted the basic configuration of your router, we will begin to setup the hotspot server and the user profiles. Open your winbox, Click IP > Hotspot on the Hotspot | Server (Hotspot window on tab server) you click Hotspot Setup and select your local interface name that was connected to hotspot network.

Next step the hotspot setup will create masquerade and network IP pool for the hotspot network. It will also create dhcp server with IP Pool to give a dynamic IP for hotspot user when connected.

Just follow the next of the setup hotspot, and you will ask any certificate that will be used by the hotspot server and define the SMTP Server. For more quickly Just follow as the pictures below!

Next step is defining the hotspot Dns Name, that allow the users  to access hotspot web login page through web browsers and finally setup the Admin User and you will get the massage “setup has completed successfully.
After this you will find the rules on firewall filter and firewall nat, dhcp server and the hotspot web login files will be created automatically on file list router when you have setup the hotspot server like above. For more details you can see the video!

2 Adjustment Hotspot Server and User Profiles

On the Hotspot | Server (Hotspot window on tab server), Click  hotspot1, you can the configuration of hotspot server  of  "hotspot1" that you have just created and you can see the configuration,  change the value "Address per MAC" : 1, to make the hotspot server more secure. Each hotspot server refers to local interface that used and IP Pool for dynamic IP network.

Hotspot | Server Profiles, click on hsprof1 you can the configuration! Each server profiles will have DNS Name for login page that related to HTML Directory that placed on File List router. Click on tab login, uncheck the option Cookie as shown like the right picture below!

Hotspot | User Profiles, we will create the some user profiles for the user hotspot. Click (+) on the tab user profiles. Give the name and the limit speed for the user who use this profile, the user will be classify using this user profile, look at the picture below!
You can use the scripts to make each user if don’t want to do manually, like the scripts below!
/ip hotspot user profile
add advertise=no address-pool=hs-pool-2 idle-timeout=none keepalive-timeout=2m name=VIP open-status-page=http-login rate-limit=720k/720k shared-users=1 status-autorefresh=1m transparent-proxy=no
add advertise=no address-pool=hs-pool-2 idle-timeout=none keepalive-timeout=2m name=Gold open-status-page=http-login rate-limit=512k/512k shared-users=1 status-autorefresh=1m transparent-proxy=no
add advertise=no address-pool=hs-pool-2 idle-timeout=none keepalive-timeout=2m name=Silver open-status-page=http-login rate-limit=256k/256k shared-users=1 status-autorefresh=1m transparent-proxy=no

Hotspot | User , first you just only have the admin user with use all hotspot server that you have, you change the configuration and choose the user profile! Just look the picture below!
If you don’t want to create the hotspot user manually, use the scripts like this!
/ip hotspot user
add disabled=no name=neeraj password=123456 profile=VIP server=hotspot1
add disabled=no name=doorat password=123456 profile=Gold server=hotspot1
add disabled=no name=weerat password=123456 profile=Silver server=hotspot1

Congratulations you have just  build the hotspot server and profiles for your hotspot network. Now you can access the internet from the hotspot server using user hotspot. You will find the web login hotspot that you must type the username and password that you have created.  Look at the picture below!
When you login as the user hotspot, you can access the internet that the bandwidth will be limited by user profile. This rule will show automatically when login on the simple queue rule of the hotspot. The bandwidth user will be managed  by user profile that you have defined it,  if you don’t use queue tree rules of the connection packets like we have talked about on the hotspot network with just using dhcp server.

You can combine the using of simple queue hotspot with queue tree rules if you require. But you must understand that the queue tree rules will handle first of the user bandwidth, It is up to you to manage which one do you like or you can combine it.

3. Customizing the Web Login Page of the hotspot user

The hotspot server profiles will related to the web login page, this file will created automatically on the File List of the router files. The hotspot web login page becomes very important thing for a variety of your purposes.  This could be a medium to promote your company a long as your radius hotspot coverage.

In order to customize and edit the hotspot login page, you can use the application such a winSCP that allow access and manage the hotspot router files. You can use the script editor such a Sublime Text that make you easily in editing the scripts that based on website scripting.

Your knowledge in HTML, CSS, Javascript, and little bit PHP is website language scripts that allow you to make the hotspot login page as your website company as you like and make it more beautiful as your website pages. I will give the example of the hotspot login pages for make you easily in customizing. But I will prepare now to move google code project hosting because google code will be turning down.

If there are problems during this implementation, let us analyze something that may cause failure on mikrotik hotspot server system to Fix and Stabilize DNS Server System
Share This Article :
Related Articles


  1. Congratulations on your article, you can send web pages? Thank You

  2. Thanks for the article. I like your blog. Keep it up.

  3. Thanks for the article! Can you share the web pages template?

  4. Thank you for these very good tutorial that helps me a lot.
    I wanted to know if:
    1. Is it possible to use an external DHCP server (ISC as DHCPd) with the hotspot without conflicts. And if possible how to link them.
    2. How can I provide access to the internet to my server stations without prior hotspot authentication. Should I meter something else in the firewalls.

  5. the boy hi, please help me I have a Cybercafe
    I want to sale time on my wifi how do i do ?

    1. Buy Mikrotik Router , its cheap router.... and configure hotspot, ppoe whatever feels good for u..... and sale bw

    2. Now you have to buy some stuffs like router then configure

  6. Tq kang tutor nya membantu buat nambah elmu neh :D

  7. When you're tired, you want to relax after a stressful working hours, you need to have time to take care of the kids active.
    Please visit our website and play exciting flash games.
    Thanks you for sharing!
    Friv 4