Graphic Web Design, Computer Network, Balinese Culture

Fix Problem DNS Server and Stabilize DNS Server
This is about the analysis of the problem dns server on mikrotik network system in distributing internet connection from ISP to the server and the clients network using mikrotik router. This problem may often found  during we have made the internet network using dhcp and hotspot server of the network system that no need to set the workgrouph and the IP for the clients unit . Perhaps some of you think that is easy problem to fix but for the beginner especially, This could be the biggest problem make they have stuck for long time to find the solution.

Actually the problem that indicates by “your dns server that might be unavailable” or other warning that blame dns server in problem, this is because the clients that using the internet can’t access or get dns server which can be caused by many things on the network system. This problem also can be caused by abnormality or the conflict on the client network system itself. You must think about where the source of the problem is. By comparing, analyzing and feeling, you should be able to guess where the main problem come, and minimize the problem scope.

Here I assume there is no problem with the lan cables, connector, router, access point and another equipment that you have used on your network and the individual or relative client problem. But the problem is just  caused by the router, access point and wan server configuration that you may have made which is the sole responsibility of us. Ok let’s see the network scheme that I have made for the example study case!

Based on the network scheme, when we have found the problem such “your dns server might  be unavailable” which one do you blame? from experience that I have found,  the internet  connection with Dns from ISP has reached to the wan server and router. But when the router continue to distribute the internet to the access point and finally to the clients are losing the DNS.

It looks like the router has failed to give the dns access that sometime bring the conflict on dns between wan server and the router.  And this problem occurs is not consistent. The instability dns that frequently occurs is not entirely due to the fault router. It also depends on the kind internet connection from your ISP. My ISP does not allow me to use another dns, such a google and opendns. If you are using the kind ISP, building local dns server will be the best choice to overcome this problem.

1. Using DHCP Client to Get Dynamic Network Address from WAN Server

In this case I have to change of the mikrotik router configurations especially to public interface setting.  I have use dhcp client to get dynamic network address of dial-up connection ISP that is shared from wan server It will create dynamic address list, change the Pref. Source, and create a new gateway reachable wan. Don’t forget to remove  the static network adress list of the public interface and the gateway route that we have used previously! look at the pictures below!

/ip dhcp-client
add interface=wan use-peer-dns=yes add-default-route=yes disabled=no

2. Create Local DNS Server on Wan Server

If you have used wan server to share the internet  connection from ISP (dial-up connection) you can create local dns server here. Local dns server will be collecting  and covering  dns from ISP and other dns. So if the client is directed to local dns server, this will be more faster . In some case local dns server can be fix problem  and stabilize dns server from mikrotik router to the client. You can build local dns server using Simple Dns plus and Bind.

3. Ensuring DNS Server Setting on The Router

Check dns settings on the router that now using dynamic servers of the wan server. This is going to be the main suspect the cause of the problem dns server that might be unavailable.  If you are not using dynamic servers, try to reset dns setting by removing this configuration at first, restart the router and try to set a new dns setting that use opendns server!

/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=,

4. Fix the Internal Network System of Wan Server & Clients from The Conflict

Wan server should not be installed by many software that may bring any conflict which can cause the internal conflicts of the network systems. If you are not sure the network system of wan server work normally. Try to reset the network system using Complete Internet Repair to fix the internal conflict network system, select the option that you want to reset! Then you setup a new configuration on wan server and build local dns server, to create dns request works more stable and faster to your network clients.

5. Bypass The Access Point using IP Bindings on The Router Hotspot Server

This is an additional on Hotspot network system, if you are using Access Point and Hotspot Server separately. IP address or Mac address of the Access Point should be bypassed on Hotspot Server configuration. We can use IP Binding to bypass Access Point, for more clearly let's see The Access Point configuration on the pictures below!

In this case Access Point is using static IP address and the dhcp server is disabled because the Access Point is the client on the hotspot server system. So the Access Point should be made as static address on the router. Click IP > ARP then on the ARP List window, right click on the IP address or Mac address Access Point and Make it Static. Next click on new terminal and choose one of the following IP Binding rules to make the configuration on the router hotspot server to bypass the Access Point IP address or Mac address that we use, look at the pictures below!

/ip hotspot ip-binding add mac-address=F4:EC:38:D6:2E:F5 type=bypassed comment "bypass access point mac address"
/ip hotspot ip-binding add address= type=bypassed comment "bypass access point ip address"

So this is all that I have done to fix and stabilize dns server system on mikrotik network, and now the hotspot clients can be access the internet that more stable. take care!
Share This Article :
Related Articles


  1. i dont understand
    i have internet by modem satlite 2 way
    i cant change dns in this modem
    so i put opendns in mikrotik but dosnt work
    dns for satlite dosnt filter websites
    is your lesson work fine to my case
    thank u

  2. i am using rb1100 with hotspot
    ip wan x.x.x.x/24
    ip lan

  3. sorry
    another info
    dhcp in modem give me 5 ip only , and i cant change any thing

  4. I am suffering from problems When the client wants to connect to maicrotik sometimes .. Can you help me To know the problems maicrotik and analyze them ?? If possible, send to my email please>> this my Email : Send me a message to give you code TeamViewer .. because I am a novice in the networks I do not want to be cause to more problems


  5. When you're tired, you want to relax after a stressful working hours, you need to have time to take care of the kids active.
    Please visit our website and play exciting flash games.
    Thanks you for sharing!
    Friv 4