Graphic Web Design, Computer Network, Balinese Culture

Loading...
16 comments

For everyone who have an internet connection from an ISP that is using PPPoE connection (Point to Point Protocol over Ethernet) it may be slightly different with how to setup it into Mikrotik router to your local internet network. Here we do not need to setup rule Ip address for the internet gateway as WAN. Instead we will use the PPPoE Client setup as a virtual interface of the gateway or wan. For you who want to learn more about the PPPoE connection, please read wiki.mikrotik.com.

Well I think you don’t waste time, lets go how to setup PPPoE Connection to Mikrotik. In here, I am using Biznet ISP as the axample for ISP that uses PPPoE Connection for their Internet. Its most commonly the same as how we setup the internet connection to mikrotik as usuall. Ok let you reset your mikrotik with no default configuration at first, before we can start.

1.  Set the name for the interface Ethernet

We put the gateway/wan cable on port1 and the local network cable on port2 on the router. So then the name of ether1 will be biznet-internet and ether2 will be lan-localnet, the rest of the ethernet ports just leave it.  Again as usual we just need two rules on it.

/interface ethernet
set [ find default-name=ether1 ] name=biznet-internet
set [ find default-name=ether2 ] name=lan-localnet


2. Setup ip address just for local networks

It is not like usual since we were using internet connection for the ISP that was using IP gateway such as Indosat. We don’t need to setup ip address for wan network mask, instead we are going to define the route for internet gateway with PPPoE Client later. In this case we just have 1 local network so the rule is just one.

/ip address
add address=192.168.1.1/24 interface=lan-localnet network=192.168.1.0


3. Setup PPPoE client for the ISP Connection on the Router

It would be the core of PPPoE setup on Mikrotik router. In this case we set MikroTik RouterOS to be a PPPoE client, we define the interface name here. Obviously we must to know the login or authentication for PPPoE connection for the ISP.

/interface pppoe-client
add add-default-route=yes disabled=no interface=biznet-internet name=BIZNET password=xxxxxxxx user=yyyyyyyyyy


4. Dns server on the routerOS for PPPoE Connection

Yet we can know that sometimes we don’t need to setup dns server on the RouterOS. It will be created automatically during we were setting PPPoE client configuration. But in another case we still need to set the dns server on the routerOS. The only thing that we can do is make sure that the routerOS have already get Dns Server from PPPoE ISP dns itself. Optionally we can add static Dns Server manually.

/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=512 servers=203.142.82.222,203.142.84.222


If we already insert the rules for dns server, try to remove all the static dns server until the routerOS has dynamic dns server. This will be the cause of the setup PPPoE intenet connection on Mikrotik router fails.

5. Masquerade Public Traffic for Lan and Setup DHCP server

This configuration rule is like usually we do, but let me give you the note. Masquerade Public Traffic on as NAT rule is using out-interface  BIZNET not biznet-internet. It must take the interface name from the PPPoE client that we have just setup.

/ip firewall nat
add action=masquerade chain=srcnat comment="Masquerade Public Traffic" out-interface=BIZNET src-address=192.168.1.0/24

the rest is creating dhcp server to provide the IP address for our local network clients

/ip pool
add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=lan-localnet name=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1


I think it is enough already. If it is not so clear for you, lets see the video below!


Related to this Topic

Somebody ask me about how to setup CCTV on mikrotik that using PPPoE Configuration Network with fixed public IP.

Ok assuming what we have is

DVR IP : 192.168.1.5 on the local network 1 : 192.168.1.0/24
TCP port : 7774
Mobile Port: 8888
Fixed Public IP: 103.12.160.202

The noted that I can suggest to avoid the problem during the CCTV setup:

1. make sure that no rules on firewall filter that probably will block connection CCTV from public IP. So you must know all the rules that you define, especially for firewall filter rules.
2. make sure that the local network has already masquerade for interface port that you were connected the DVR CCTV to that network.
3. Some kind like port forwarding divice port, DVR port on our local network with NAT rules

/ip firewall nat
add action=dst-nat chain=dstnat dst-address=103.12.160.202 dst-port=7774 protocol=tcp to-addresses=192.168.3.5 to-ports=7774 comment="CCTV Local Inbound"
add action=dst-nat chain=dstnat dst-address=103.12.160.202 dst-port=8888 protocol=tcp to-addresses=192.168.3.5 to-ports=8888 comment="CCTV Mobile Inbound"

4. make sure that DVR port is already open. You may use yougetsignal.com from IP public.

Share This Article :
Related Articles

16 comments :

  1. Its a wonderful post and very helpful, thanks for all this information. You are including better information regarding this topic in an effective way.Thank you so much

    Personal Installment Loans
    Payday Cash Advance loan
    Title Car loan
    Cash Advance Loan

    ReplyDelete
  2. Nice article great post comment information thanks for sharing

    หนังซอมบี้

    ReplyDelete

  3. คาสิโน Online gambling site Free life is easy to play. Do not waste time and trouble traveling. Travel makes us spend a lot of money. And also have to spend days. This has evolved. Online gambling continues to grow. By gambling online Have gambling online. Everyone is more interested in betting and betting. Get ready for a glimpse into the gambling experience and experience the ultimate in gambling without borders. The life of a free bet, the comfort, the advancement of the modern age. And get special discount on playing games that enjoy online gaming moods that make good things for ourselves. With great promotions Special privileges for various gambling luck. Online gambling games, social advancement. Ready to answer the problem of good bet. Interested in touch with the fun. Better ways to live Games that are comfortable every day. Every comment to play a new generation. Have fun with us at the web. Gclub

    ReplyDelete
  4. คาสิโนออนไลน์ Online Gambling Gambling Sites Gambling is more easy to play. By choosing to play in online format. The open activity for everyone to join the game easily. Enjoy the fun of all ages. Open service is no ceremony. Ready for new fun freedom life Betting games that are ready to serve as a friendly. There are new games that everyone can play at home. Only subscribers can join online gambling with us. Worth the enjoyment Go to activities that go far. Open a good service to get rich first. The game meets the auras that convey happiness. People have read. Different gambling techniques. With great betting techniques to gamble, play often. The way to leading gambling. The way to play free games. Gambling creates new channels of interest. We have more than 30 million baht worth of prizes for those who are interested in our games. In the pursuit of pleasure, the web is really open.Ruby888

    ReplyDelete
  5. I really like you post good blog,Thanks for your sharing.

    ดูหนังออนไลน์

    ReplyDelete
  6. คาสิโน Online gambling sites are open to everyone to enjoy each day. Modern Games Gambling is a game that is constantly popular. Get ready for all the moments of entertainment that lead to a bright future. The casino is a game that brings fun to the streets of gambling, ready to answer every moment of fun at anyone. I choose to play all the time. Playing Gambling Games At the time of popular enjoyment. Gambling for fun all day. Make your way to a great new social gaming opportunity. Start a fun and endless game online. Easy Gambling Top Gambling Games Enjoy the most exciting moment. Moreover We also have a great offer. Called a game that is easy to understand. Just by playing on your mobile device, tapping the phone, you can access online betting instantly. We care about everyone who wants to get into online poker today.Gclub

    ReplyDelete
  7. Royal1688 Online Gambling Games Site Life is easy to play. Welcome everyone to the most popular activities. Play at home. Most of the fun that is new to the players who are interested in fun. We offer a wide selection of gambling options that you can not miss. Play free online games. Have a modern opinion. The game gives you all the modern life. The perfect happiness. Opportunity to enter the era. Games that make choices in every society at all times. Games that welcome anyone to join online gambling. Fun to share There are a lot of opportunities to win big money to win a lot of popular luck. Find the future of Thai society. Nowadays, gambling is a big money market. To play the game with us. We give you the opportunity to choose good things for yourself, open the options to get to know the simple play. Make money every day through the web.Goldclub Slot

    ReplyDelete
  8. IBCbet New Age Gambling Website Turn to the online entertainment where everyone is interested in creating fun, open the channels of entertainment that welcome everyone to the path of social fun. An alternative to the exhilarating view of gambling, such as online gambling, the ultimate gaming experience, and the launch of a unique financial channel. Gambling Online There are more than 200 gambling games to win a jackpot of up to 30 million. Sink easy to get promotions, discounts, privileges. A lot of fun to open. Get started on the chance to create a chance for everyone to play. The game is fast approaching. Do not waste time traveling any further, opening a gambling perspective into a bright future. Betting Odds Play the game in the way you want to enjoy the new game to create a happy new gambling. Choose to play in the modern era. Make the most of it. Do you want to play games in the modern era with pleasure on the web.Sbobet

    ReplyDelete
  9. Many betting games do not make the player miss entertainment.
    viva9988Online casino game service providers are ready to provide players with an entertaining betting game in an amazing form. New online casino brings players to entertainment. With a standard online casino site, it is also open 24 hours a day for gamblers to enjoy their favorite online casino anytime. Nowadays, online casinos are set up to accommodate the comfort of players. Players play online casino games without having to download the program because they can bet on the web page directly. The ultimate in online casino gambling entertainment. Not only that, players can earn money from every game, but how much depends on the skill and the player as well. Can I find or learn a good technique? Before placing bets. So everyone can play it. Have fun with the money with a new online casino game with continuous service. Easy to use and access to our online casino games on a variety of channels. Online Casinos Gambling Betting Fun and Surprisingly With All Games Bettingจีคลับ

    ReplyDelete
  10. Online Gambling Anyone can play it
    รูบี้888Is a web-based online gambling site with a reputation for fun, open to the joy and fun for more than 10 years, the casino society is known and became accepted in just a few minutes. Long time ago, playing online gambling games was one of the first places of great wealth. Anyone who can join and start rich is not difficult. As a result of playing online gambling games in each form, the player or ordinary people become the highest income in the country and the highest in the world because of the income from playing games. Online casino games are very easy. Since every time a bettor overcame an online gambler, the bettor was able to make an income from playing the online gambling game as well, just as the player bets on the gambling and playing online gambling games. With casino site Our gambling player can make money from playing online gambling with a player around the world if you want to know that money from the online game is very risky. Any bettor can come up with a proof of that on the site รอยัล1688

    ReplyDelete

  11. Royal1688 Gaming Website in Contemporary Gambling New Opportunities for New Ways Play Online Casino Games Join the fun game in the game and open the way to a worthwhile chance. Start with the chance to meet the perfect life. The online casino is popular online. Developed and forwarded games for better communication. Fun to be around is a game that complements the channel close to many people to gamble through the fun of online gambling. Challenge Activities Start from what should be, no matter what kind of gambling game you are. The game is a good choice. The game has a positive feedback to itself. Have fun every day. Interested in the fun of playing the best match. The best open source betting option. Win money to be added to all of them as well. Interested in playing games in the current period. You can choose to play the casino game easy money through the website.Goldclub Slot

    ReplyDelete
  12. Online gambling makes you rich.
    จีคลับIs a popular online casino site that has been providing online gambling for more than 10 years with a system that offers the latest casino games. This club is well-known and popular today, and most importantly, the gambling club website. This online casino is also an opportunity to play online casino games in each form is easy to access, and importantly, every player can now play all online gambling games. model You do not have to download the program to play time because the service of the website gclub. This online casino is open to play online gambling games, with just the internet, you can play all kinds of online casino games. The challenge and excitement of this service is open and the system is available in accordance with the age, so all players are able to access online gambling every time anytime. And when you want to play online gambling games, it's just a click bettor on the webRuby888


    ReplyDelete

  13. IBCbet Online Gambling Games Games that have long been a favorite of betting. People are very interested in online gambling because it is a simple game that can be gambling at home. Or anywhere. You want to gamble in your spare time. Nowadays, online casino websites have developed better online game systems. There are also many promotions and discounts. Our games reward the needs of gamblers who bet. Play games that are a pleasure of all ages to earn extra income is good. How to choose the best financial solution. The opportunity to gamble. Getting Started With Gambling Developed a new way to play. Create your own expertise. Open every chance to win luck in the modern era. The choice to gamble is fun. Opportunity to gamble Win a lot of money. Welcome everyone with a willingness. We give the best to everyone. In full format Social Gambling Have fun at the web.Sbobet

    ReplyDelete
  14. Real Play Free Play
    Gclub SlotBetting on Online Casinos is a great way to earn money online. Many new online casinos that will make you gambling. With the kind of risky online games that play comfortably. The opportunity of gambling to win online gambling. With hundreds of online games to choose from. Online gambling games are popular among gamblers around the world. This is because they can bet on the full scale and earn money from the games. The atmosphere of online casino games is more realistic by live casino games online. With sharp images, play without interruption. Giving the best online gamble to the consumer. Not only that, they can find tips and entertainment with other buyers. Entertainment is not a holiday to open the risky online games that meet the needs of customers. If you are interested or are looking for ways to make extra money to customers. Win a game online is a way to choose which can meet all users needs. Holiday Palace

    ReplyDelete
  15. The best online casino games that give real money.
    GclubThe online gaming service provides you with unmatched levels of excitement. Win online games that give you a better bet. No matter what kind of online casino is available, it will make the path rich. Do you want to get rich with online casino games that will satisfy all your needs? Play free online games that you can play in real time with the mobile phone easily. In addition, our online games are open to unlimited online services without any holidays, when to use the service at all. Not only this, the online risky website also brings the games that are designed to be easy to understand and can be gambled over. In order to meet the needs of new gamblers or online gamblers. Win online games that serve you all as expert. And also bring good privileges with bonus promotions as well as overwhelming profits that will make you bet on our site worthwhile. The choice of fun with online gambling is always available. And provide money and wealth to customers. Royal1688

    ReplyDelete
  16. Your blog is very useful for me,Thanks for your sharing.

    หนังซอมบี้

    ReplyDelete

Back to Top