Graphic Motion Video Art, Website, IT Network, Culture

Loading...
9 comments

Netcut is the software that has an ability to control the internet connection in the same network interface of the router. By scanning IP address to all the device that connected with the same network. Netcut can be used to get and take over the network client devices and can do anything with the internet connection for all devices as the network clients. Netcut is used by someone inside the local network as part of our network clients. It most probably used on wifi connection after the client is login.

There are some kind Netcut software out of there. But one of the most powerful netcut software which is has very complete ability as I have found so far is P2pover. First I know P2pover is used by my client that want to cut another network clients for the internet connection. Hoping to get faster internet connection of other clients. I was very surprised this kind netcut, because it is really work, this software can be used to manage our bandwidth clients like an admin of the network. P2pover can cut or drop, limit, filter and others inside our network. As an admin, it might be an alternative way to manage the internet usage by the clients. But if the client is used, it could be a big problem. One client that uses this kind netcut software will tend to do a bed thing to another clients for their personal reasons.


As the picture above the client that used P2pover which is without any login the software, it will able to scan all the clients IP in the same network. After that can be create or define the rules to limit the internet speed like we are doing as an admin on mikrotik. It is possible until kill or cut the internet connection to another clients until out of the network. If more than one client do like this, you can imagine what would happen with our network services. We as the admin or IT network just receive much complain that will be angry with a this chaos, and most probably one of them will be gone. This would be a terrible threat, does it not? You are in the same boat, we must dealt with some kind the netcut software, so that no netcut anymore between our network clients and the mikrotik. 

In order to prevent from netcut attack on mikrotik network, there a few method to do so. Some tutorial may advice such as creating any rules to block netcut on firewall filter mikrotik. Prevent the clients creating static IP by themselves so that the IP address that used by any clients just come from dhcp server on mikrotik, like the picture below! 



For such kind netcut software like P2pover, none of those method that I mention above during my experiment to block P2pover, it won't work perfectly. It looks like need another way that can strictly and powerful to block P2pover on our mikrotik network. Especially for you that is using wireless interface of mikrotik you must isolate communication between the clients by disable default forward so the clients can not communicate each other. The same thing if you have use wireless router like TP-link try to enable AP isolation.

This is one of the most powerful way in order to stop at all the netcut and protect the clients on our mikrotik network. This is the smart method by using trick to hide the real IP gateway from netcut, so that the netcut will never know the access gateway for the interfaces that we have used on mikrotik router. Ok I assumes that you have used 4 local network interfaces and 1 public interface as reflected by the rules below!

Configuration Before Block Netcut is Implemented on Mikrotik

/ip address
add address=192.168.1.2/24 interface=internet network=192.168.1.0
add address=192.168.2.1/24 interface=localnet-1 network=192.168.2.0
add address=192.168.3.1/24 interface=localnet-2 network=192.168.3.0
add address=192.168.4.1/24 interface=localnet-3 network=192.168.4.0
add address=192.168.5.1/24 interface=localnet-4 network=192.168.5.0


And dhcp server network would be like this rules:

/ip dhcp-server network
add address=192.168.2.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.2.1
add address=192.168.3.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.3.1
add address=192.168.4.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.4.1
add address=192.168.5.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.5.1



We are going to hide the real IP gateway that used by every local network of the router interfaces. This method has found by someone from many many experiment. It looks like little funny by using fake IP gateway on dhcp server network such as:

dhcp gateway IP for localnet-1 : 1.1.1.1
dhcp gateway IP for localnet-2 : 2.2.2.2
dhcp gateway IP for localnet-3 : 3.3.3.3
dhcp gateway IP for localnet-4 : 4.4.4.4

Change the gateway IP of dhcp server network for each interfaces that you want to protect our network clients against netcut or remove dhcp server network rules and insert the new rules for dhcp server network like this:

Configuration After Block Netcut is Implemented on Mikrotik

/ip dhcp-server network
add address=192.168.2.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=1.1.1.1
add address=192.168.3.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=2.2.2.2
add address=192.168.4.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=3.3.3.3
add address=192.168.5.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=4.4.4.4

So the result of dhcp server network after changing would be like this!


In order to make this gateway IP work, we need to add the new rules of network IP address for each interfaces. The rules that we need to add would be like this!

/ip address
add address=1.1.1.1/24 interface=localnet-1 network=1.1.1.0
add address=2.2.2.2/24 interface=localnet-2 network=2.2.2.0
add address=3.3.3.3/24 interface=localnet-3 network=3.3.3.0
add address=4.4.4.4/24 interface=localnet-4 network=4.4.4.0


It looks like little bit funny or non theoretical, but its really realy work, it will not effect anything with the internet connection for all the network clients. It just hide the real gateway IP and make the netcut software stuck will never know the right gateway IP for every network router interfaces. Finally no netcut anymore between mikrotik and network client.

My notice here if sometime you want to use external wifi router to interface that have been setup to be anti netcut, you should not use automatic configuration on external wifi router. But you have to setup manually of wan interface gateway that must be using the real gateway IP from the mikrotik router interfaces. That’s all about the smart and powerful way to stop netcut on mikrotik, give a try! and for more clearly lets watch the video! See you!


Share This Article :
Related Articles

9 comments :

  1. Meet all the requirements with online casino games.
    SbobetOnline casino games provide the best entertainment from online casino games. Online casino games that are easy to bet on the needs of today's players as well. Online casino games give you a better experience of betting. With online casinos weaving live, which gives the gamers a more realistic betting experience. Online casino games are available 24 hours a day to accommodate players with different free time. The use of online casino services that are available to play a wide range of games can bring better entertainment and can also create better entertainment. If you want to use a betting service or are looking for a new way to win. We are the choice for you whether to use a secure online casino. Easy access with a variety of entrances. It is ready to entertain you at any time. Do not be disappointed with the online casino games designed for a new player. Have fun at your leisure. คาสิโน

    ReplyDelete
  2. Online gambling has better entertainment.
    Goldclub SlotIt is a great way to start playing online gambling games at the best online gambling sites. Win a chance to win no limit online. The customer can risk the online fortune of our website whenever you want. Online gambling betting opportunities suitable for all types of gamblers. Gold to the joy. Every game is a gamble to be sure that the players are ready to bet. And can meet the needs of online gambling games are open all the time. And online gambling games where you choose to gamble. Online casino games more than 100 games to bring joy. Excited to you constantly. Online casino games and players will be more than entertainment. We offer online casino services that are all so popular and popular. Do not miss the chance to win live online and also promote. Special offer for new members and get up to 500 free credits to gamble. All bets are free to play. คาสิโนออนไลน์

    ReplyDelete
  3. I like your post. It really useful with me. Thanks for sharing these useful information!
    happywheels3game.com

    ReplyDelete
  4. Thanks for providing good information,Thanks for your sharing.

    หนังออนไลน์

    ReplyDelete
  5. I totally loved the way you presented the topic. Your way of presenting is good.

    Selenium Training in Chennai

    ReplyDelete
  6. Very nice post.really I apperciate your blog.Thanks for sharing.keep sharing more blogs.

    ดูหนัง

    ReplyDelete
  7. Its an awesome article. written in very creative way and it also conveys useful information.

    BIGDATATraining in Chennai

    ReplyDelete

Back to Top