Graphic Motion Video Art, Website, IT Network, Culture

Loading...
25 comments

Learning Network using Mikrotik with the router OS was very fun. At this moment I would like to write the note about how to remote or access DVR as the camera/CCTV server on our Mikrotik network by creating port forwarding rules on firewall nat of the Mikrotik router OS. Maybe you be like me wanted to be able to see a certain place that you feel important to keep safe in your observation wherever you are. It doesn't look to be such a big deal, your eyesight is in your hands right now on your mobile.

Obviously for the security reasons you need surveillance system at the office or even your home. Installation CCTV (Closed Circuit Television) camera is not difficult matter. I think right now you wanted to buy the camera and hoping to be able to see the place where you think it might be necessary for you. Perhaps you have CCTV installed already, but don’t quite know the CCTV network system. I hope after this you can manage your CCTV network by your self. Lets take a look the schematic picture below!


Based on the schematic picture above, we have the internet connection with static public IP connected to port 1 of wan mikrotik interface named as internet. The internet goes into the router and out to the network through port 4 of local network interface named as localnet-3. Then the Internet connection which is already masquerade by the router will be shared to the local area network using switch/hub. DVR CCTV server as the device client of the local network must be set using static IP, it can be done by setting DVR server lonely like you set the IP the configuration on the PC client that uses static IP. DVR CCTV server usually has the port that you can set manually, or just leave the port number by default manufacture, you just need to know what the port that used to access DVR as CCTV server.

As probably you know, there are two kind of the cameras/CCTV such as Analog Camera which is using coaxial cable, its kind like commonly antenna cable television connected to DVR and IP Camera which is using LAN cable. Surely when you buy the cameras you must know the kind of DVR as the camera server, its using coaxial cable or LAN cable that will connected to. In this implementation I was used Analog Cameras and The DVR. DVR will act as the server of cameras to view and record the showing what the camera captures.

In this case I am not showing you how to setup DVR as the server, its probably a less of my record. But trust me it is easy its depends on the brand of your DVR that you have. If you want to setup the DVR, you can connect the screen, maybe PC monitor must be connected to DVR, you can plug in PC mouse and keyboard if needed, then start on the DVR. DVR will ask you the login password to access DVR menu. The default login may you can find at the body chasing of DVR itself. After you have logged in, you begin to setup DVR configuration, its truly depending on yours. Just for the reference:

IP address (static) : 192.168.3.5
Subnet Mask: 255.255.255.0
Default Gateway (real) : 192.168.3.1
Preferred dns server : 8.8.8.8
Alternate dns server : 8.8.4.4


Media Port : 34567
Mobile Port: 5000


So that is the point of DVR configuration, once again its depending on your network environment that you have. Some of DVR may does not have or provide you Media Port. In this condition you have to access the camera server just from the mobile port by your mobile phone through internet from outside of your network.

As the schematic picture, let's assume:

Mikrotik Router Configuration:

Wan/public Interface : Internet
Public Network : 114.6.112.92/30
Gateway IP : 114.6.112.93
Public IP: 114.6.112.94

Lan/Local Interface : localnet-3
Local Network : 192.168.3.0/24
Gateway IP : 192.168.3.1


PC Security Monitor:

IP address (dynamic) : 192.168.3.13
Subnet Mask: 255.255.255.0
Default Gateway (real) : 192.168.3.1
Preferred dns server : 8.8.8.8
Alternate dns server : 8.8.4.4


According to this condition, what would you like to do?

1. Access DVR CCTV Server Displaying the Cameras View from Local Network

Our aim to access DVR CCTV server through local network in the same local port interface of mikrotik router we don’t need to add or create the new rules of the mikrotik configuration that has been run. If your DVR has provided the Camera Client View software, you can install the software on PC client, in this case is PC Security Monitor. But if your DVR doesn’t provide any software, you may need third party software like CMS2000. I believe you just like free software!



The you make the configuration to access DVR CCTV server from local network in the same interface or DHCP server of the router. Create the name of the configuration, login password for DVR that you have setup earlier, insert DVR IP address and media port that’s used to access DVR server. Some people commonly use 34567 | 7000 | 8000 | 9000 as media port DVR. Just my opinion leave the port configuration by default manufacture for not invite any trouble during the setup.

If you have got the problem in accessing DVR CCTV server from local network, it most probably caused by PC client that you have used is in different interface or network/subnet. When you using different interface like this, you may need to setup the bridge on the router, or you just can access from public IP router itself. So to avoid any problem during the configuration, simply just put PC client monitoring in the same interface or network of the router. Another thing that could be the cause is firewall filter rules on the router that may block the connection. DVR server is hang can be the cause of  the problem too, try reset the DVR. The last possibility is DVR is broken system, buy the new one, lol!

2. Access DVR CCTV Server Displaying the Cameras View from Internet 

This will be the main thing that I want to explain, which is the main goal is how we can access DVR CCTV camera everywhere as long as we have internet connection. This is the way how we can access the cameras through public IP of the Mikrotik as the router of the network where the DVR CCTV is located. Lets assume that we have public IP which is not changed or static 114.6.112.94. So knowing your ISP internet connection IP, you have private Public IP or not.

We should create the new rules port forwarding media and mobile port DVR on firewall nat Mikrotik. The same kind like what I have done as the article Building Web Hosting Server. So have to create two rules port forwarding for each port DVR like below!

/ip firewall nat
add action=dst-nat chain=dstnat comment="CCTV Media Port Fowarding" dst-address=114.6.112.94 dst-port=34567 protocol=tcp to-addresses=192.168.3.5 to-ports=34567
add action=dst-nat chain=dstnat comment="CCTV Mobile Port Fowarding" dst-address=114.6.112.94 dst-port=5000 protocol=tcp to-addresses=192.168.3.5 to-ports=5000



Simply I just can say, we do CCTV media port forwarding to public IP media port will be forwarding to DVR IP media port that just using TCP protocol. This will allow you in order to access DVR CCTV server through public IP using PC or laptop with camera client view software like CMS2000.

On the other part, we also add the rule for CCTV mobile port forwarding, that will allow you to access DVR CCTV server using mobile device with any mobile application like HDIVS. HDIVS is available on android and iOS of your mobile phone.

We have done in adding the rules port forwarding on mikrotik firewall nat, next we ready to install camera client view software on PC/laptop (CMS2000) and camera client view app on mobile device(HDIVS). Just like what we have been done like we setup Local Access DVR CCTV Server Displaying the Cameras View from Local Network, but now we are going to use the Public IP on the configuration as shown like the picture below!



The picture above is how we configure the camera client view software in this case CMS2000 on the laptop to access the camera from public IP DVR Server. It assumes you have private public IP from your ISP on DVR CCTV server.

In the most cases you gonna need to access the camera just wherever you want. For this kind purposes you have to setup camera client app on your mobile device that has connection to the internet. The picture below is how you can configure HDIVS app on your mobile device! 



If you have found any problem in accessing DVR CCTV Server Displaying the Cameras View remotely through internet or public IP. Try to cross check you have the right way in creating the new rules port forwarding media and mobile port DVR on firewall nat Mikrotik about public IP of DVR server side. Make sure access media and mobile port has been opened. Go to yougetsignal.com type your public IP with media and mobile port that should be opened, like the picture below!



It’s impossible to access the camera remotely through internet since you have found the port is still closed. Try to check the firewall rules and make sure there’s no rule has block the port access. In most cases try to reboot the DVR CCTV Camera Server.

So that’s the concept how we can access DVR CCTV Camera Server from local network and remotely through public IP. Perhaps some of you have wondering how about if we have just dynamic public IP on the camera server. It can be solve by accessing from ddns domain name.

Please read how setup noIP on the article Build Web Hosting Server by self Using Dynamic IP. After you have domain name on noip.com and related to your dynamic public IP, you must keep it in up to date by using Script Automatic Update Dynamic IP into the router like the script below!

/system script
add name=no-ip_ddns_update policy=read,write,test source={
 :local noipuser "your_user_login_noIP"
 :local noippass "your_password_login_noIP"
 :local noiphost "yourdomain.ddns.net"
 :local inetinterface "your_wan_interface_router"
 :global previousIP
 :if ([/interface get $inetinterface value-name=running]) do={
  :log info "Fetching current IP"
  /tool fetch url="https://www.trackip.net/ip" mode=http dst-path=mypublicip.txt
  :local currentIP [/file get mypublicip.txt contents]
  :log info "Fetched current IP as $currentIP"
  :for i from=( [:len $currentIP] - 1) to=0 do={
   :if ( [:pick $currentIP $i] = "/") do={
    :set currentIP [:pick $currentIP 0 $i]
   }
  }
  :if ($currentIP != $previousIP) do={
   :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
   :set previousIP $currentIP
   :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
   :local noiphostarray
   :set noiphostarray [:toarray $noiphost]
   :foreach host in=$noiphostarray do={
    :log info "No-IP: Sending update for $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
   }
  }  else={
   :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
  }
 } else={
  :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
 }
}

/system scheduler
add interval=2m name=no-ip_ddns_update on-event=no-ip_ddns_update policy=read,write,test comment="Update No-IP DDNS" disabled=no

By using Script Automatic Update Dynamic IP, the router will working in updating your Dynamic IP still related to ddns domain noip in order to access the camera. In this condition we do a little bit changed for the rules port forwarding DVR CCTV Camera Server that is no longer using public IP, otherwise it must be refer to wan interface router like the rules below!

/ip firewall nat
add action=dst-nat chain=dstnat comment="CCTV Media Port Fowarding" in-interface= your_wan_interface_router dst-port=34567 protocol=tcp to-addresses=192.168.3.5 to-ports=34567
add action=dst-nat chain=dstnat comment="CCTV Mobile Port Fowarding" in-interface= your_wan_interface_router dst-port=5000 protocol=tcp to-addresses=192.168.3.5 to-ports=5000


That’s all about the accessing DVR CCTV Camera Server on our Mikrotik network, for more clearly, you may need watching the video, have a good day!



Share This Article :
Related Articles

25 comments :

  1. this is nice post networking is one of the very topic to studied if anyone learn the this they will control the world.thanks to sharing this information to us.
    MSBI Training in Chennai

    ReplyDelete
  2. Have a real gamble every game, bet.
    จีคลับ It is another online gaming site to win great prizes in online gambling. It can be played in both mobile phones and computers with the chance to gamble comfortably. Find out the profit with online lucky draw games that will give you the best results. All games are fully open with full online gambling. Play all games with no restrictions. No need to install the application. Because it can play through the page in front of me. Nowadays, online gambling games have been accepted by many gamblers. Because gambling through the internet is very convenient, it can also earn money or money from real money. A lot of fun created for you to bet on consistently. Regardless of whether the player will use the service to win money online, we are ready to serve. Do not miss out on favorite online bets that are geared towards creating superior gambling and for the players. If you want to bet the most fun games of gambling can be gambling every moment. บาคาร่า

    ReplyDelete
  3. Thanks for spending your valuable time in delivering the most valuable content here.I loved the way you write and suggest my friends too for getting aware of your blogs.
    Pawn Shops in Montgomery
    Pawn Shops in Birmingham
    Pawn Shops in Mobile

    ReplyDelete
  4. Online casino games meet all players.
    Gclub SlotIs a channel to play online games that can meet the needs of players ready to play online gambling in real life. Online casinos are inherited from the famous risk sources of Cambodia. Casino Poipet Casino Resort Fun to enjoy the service and enjoy the taste. Because of the type of gambling games, the new format is both easy to understand. Challenge the experience of gambling to continue. Guaranteed fun from the website that has long been accepted and accepted by the gambler to play. We are the leading online gambling site in Thailand. Realistic, open to the players 24 hours a team of experts to recommend. Consultations and inquiries About gambling games at any time. Take the chance to win a chance to win the game online to challenge the game. Moreover, the money spent on the service game. All games are ready to make rich users shortcuts. The choice of the most popular online gambling casinos is waiting for the players to come and play all the time, click here. Holiday Palace

    ReplyDelete
  5. Nice article great post comment information thanks for sharing

    หนังออนไลน์

    ReplyDelete
  6. Entertainment gives you 24 hours with online casinos.
    Ruby888It is another online casino games site that can provide you with a real risky online betting experience. Online horoscope has been broadcast online from the famous gambling source of Cambodia. Casino Poipet Casino Resort Enjoy the fun and full of fun to win. Because of the new type of gambling games, both the easy understanding. The challenge is to deliver on the experience of gambling. Guarantee the fun of a long-established website as well as the recognition of the player who bets. We are the leading online gambling site in Thailand. Realistically open to players all day and all night. There is a team of experts who provide advice. Ask for opinions and ask questions. About Betting Games Anytime Online gambling online that will give players a chance to challenge the game. Moreover, the money spent on the service game. All games are ready to make you rich. The opportunity of online casino gambling that most users wait to use the service every click. IBCbet

    ReplyDelete
  7. The International League of Antiquarian Booksellers has published a lists detailing all the texts believed to have been stolen during the burglary.Smarter Security Melbourne

    ReplyDelete
  8. We need to play rich online games.
    รอยัล1688The web is open at Poipet. Casinos casinos that risk can play all forms of luck. The Internet only to play. Every time an internet player bets, the player can play all online gambling on the site of this online casino. The online casino site. It's a fun and fun new opportunity for people who are passionate about gambling and gambling. Because of this, online gambling games in each form are constantly being developed. It makes playing online casino games at this time is well-known and popular in it. Whether it is a player. Thais or foreigners are passionate about playing online gambling games as well, because online gambling in each form is both joyful and fluent in playing and important to gambling. Online gambling is also a new safe choice, a player can play all kinds of online casino games through the Internet. Brannon's not a player where he can play and bet online. When thinking about online gambling, remember to think of web services viva3388

    ReplyDelete
  9. Online Gambling Make you rich
    viva9988G-Club Website Online casino named. One of the richest ways that a bettor can not miss because every time a risk comes to play casino games online casino site. Our gambler will know the main reason why most gamblers choose to play online casino games with us. Online gambling in each form is available on the casino web site. Our club is an online gambling that was chosen as well. And more importantly. Playing Online Gambling Games on Casino Websites Our club also has a maximum bonus of up to two hundred thousand baht, so it is not strange that now our online casino has the largest number of members. Admit it as a casino web site. The top clubs that the player chooses to use it. So if you are thinking of playing online casino games, do not forget to choose the web gambling club. Our online casino because we are willing to serve the player every time the bettor wishes. Bets can be found and experience the atmosphere of playing online gambling games with the players around the world all day and night at the site จีคลับ

    ReplyDelete
  10. I like your post. It really useful with me. Thanks for sharing these useful information!
    happywheels3game.com

    ReplyDelete
  11. Your blog is very useful for me,Thanks for your sharing.

    หนังออนไลน์

    ReplyDelete
  12. If you need great price information about DEFENDER 21006 Ultra High Resolution Outdoor Security Cameras - 4 Pack, you can click here and you can see good information price for DEFENDER 21006 Ultra High Resolution Outdoor Security Cameras - 4 PackSmarter Alarm Systems

    ReplyDelete
  13. Hence, you can significantly reduce your chances of being burglarized by being proactive, developing good habits, and implementing a home security plan. Smarter Security

    ReplyDelete
  14. I really like you post good blog,Thanks for your sharing.

    ดูหนัง

    ReplyDelete
  15. It has been simply incredibly generous with you to provide openly what exactly many individuals would’ve marketed for an eBook to end up making some cash for their end, primarily given that you could have tried it in the event you wanted.

    Bigdata Training in Chennai

    ReplyDelete
  16. Thanks for sharing and great tips and solution HP Support Phone Number

    ReplyDelete
  17. Mobile Surveillance SystemSolar Mobile Surveillance System's are one of the exclusive products offered. The Mobile Camera Tower surveillance offers a new, innovative, ready-to-use system

    ReplyDelete
  18. To protect the stonework from pollution, internal combustion engines are banned near the Taj so we travelled the last two hundred metres in an electric tuk-tuk. We would have been happy to walk, and given the air quality in India's major cities, I doubt that a two hundred metre cordon sanitaire makes a significant difference, but it provides much-needed jobs for drivers.

    Latest News India | Online Breaking News

    ReplyDelete
  19. Your post is really very interesting and informative. Such a great information you shared with us. Thank you so much for sharing it.
    trips for college students

    ReplyDelete
  20. Nice tips you shared with us! If you want to travel with student group then book a trip with educational tours for students in india

    ReplyDelete
  21. Wonderful tips! Thank you so much for sharing a wonderful post!
    educational field trips

    ReplyDelete
  22. The blog has also brought me in contact with chefs and restaurants. If you visit a place often, you are bound to be taken care of by them. Its called 'regulars', I also have that tag and that makes it very difficult to objectively write about service.

    Restaurants in OMR

    ReplyDelete
  23. Urban population specifically has become very conscious of the important aspect of home security. India security system has several useful tools available to protect your beloved home. Smarter Security Melbourne

    ReplyDelete
  24. It is good to know that there are posts regarding topics like these. We are cctv camera dealers in Chennai and posts like these are very useful for our team to upgrade ourselves and enhance our knowledge regarding security systems.

    ReplyDelete
  25. Excellent post you have to shared. very interesting and informative. we are doing CCTV Camera business.
    CCTV Camera Dealers in Chennai
    CCTV Camera Installation Chennai

    ReplyDelete

Back to Top