Graphic Motion Video Art, Website, IT Network, Culture

Loading...
Fix Total Bytes Dynamic Simple Queue Mikrotik

If you would like to manage bandwidth of the internet connection using simple queue for some other reason, you will get the information about  total rx bytes, total tx bytes, and total bytes usage on each client IP. In some other case we need the total tx bytes to accumulate the total rx bytes as total upload bytes and the total tx bytes as total download bytes. But it is possible when the total bytes still 0 or not accumulate tx and rx bytes. It would be a problem if you run the system script on your router mikrotik that using the total bytes. Therefore you must find the way how to make the total bytes can be accumulate those tx and rx bytes.

For now I would like to show you, how can to setup the simple queue to fix total bytes that can not accumulate total tx bytes and total rx bytes so that the total bytes is not 0. I would like to apply it on a dynamic simple queue that might you need for those of you that use wireless LAN of the internet connection network in which the client using dynamic IP address. Dynamic IP address that is using by the clients always change at time. You need to make the simple queue with with the Ip address range will be xxx.xxx.xxx.1 - xxx.xxx.xxx.254 on each clients that maybe used.

Suppose that my router mikrotik has an IP address 192.168.1.1, it would a default  gateway for the internet connectivity of my internet network, in this case I must setup the all clients ip address from 192.168.1.1 until 192.168.254.
  • 192.168.1.0 is a private my ip network as a default network, but not default address. It is used in routing tables and by the Internet Protocol internally to identify the 192.168.1.x network as a whole.
  • 192.168.1.255 is The broadcast address of my network that  is used to send data to ALL clients on my network.
In order to make the simple queue to all the clients with IP address 192.168.1.1 – 192.168.1.254, it would be a long time to make it manually. We have to use  script to make all of them automatically. You can use the script below to make all of those simple queue Ip addresses :

/queue simple
:for i from=1 to=254 do={
 add name=("Client $i") target-addresses=("192.168.1.$i") \
 dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=256000/256000 disabled=no
}

This is the script to make all dynamic simple queue that may used by the clients of the network 192.168.1.x. All of the ip addres simple queue will create automatically. You can adjust max-limit value and others. it would be the same value to all the client IP address.


Look at the picture above! the client name according to Client $i and have the same max-limit = 256 kbps. From here you can see total bytes is 0, it doesn’t accumulate total rx bytes and total tx bytes usage. Have you found the problem like this? Double click on the simple queue that you use, on the simple queue window, click on total tab. There is total queue type and it might setup by default as default-small, and change it to be default and click ok. Look at the picture below!

If setup the simple queue complete with Total Queue Type = Default, you can check again the total bytes usage of the clients, for more precisely, click on reset all counter, It is going to be like the picture below!


Total Bytes = Total Rx Bytes + Total Rx Bytes, as we expected. Now how about to change All of the clients simple queue to set to be total queue type = default automatically. I think we just need to change the script, after you remove all dynamic simple queue before. The script that changed would be like this!

/queue simple
:for i from=1 to=254 do={
 add name=("Client $i") target-addresses=("192.168.1.$i") \
 total-queue=default interface=all limit-at=0/0 max-limit=256000/256000 disabled=no
}

If it is not clear enough, let’s see the following video! good luck for you!


Share This Article :
Related Articles

4 comments :

  1. Internet Download Manager drop ?????????MikroTik v 5.26

    ReplyDelete
  2. Hi,
    This is interesting and very handy but is there any chance to manipulate the script so that it works with OS 6.33.5?
    Thanks

    ReplyDelete
  3. Hi,
    This is interesting and very handy but is there any chance to manipulate the script so that it works with OS 6.33.5?
    Thanks

    ReplyDelete
  4. A variety of casino games that are played.
    บาคาร่าออนไลน์ One of the most popular online gambling sites is the online gambling house where gamers enjoy gambling. Continuing with online gambling can be a chance to win all 24 hours. Our online gambling games are created for gamblers to easily risk their lives. Bet on online games that can generate a wide range of profits, which will make the bettor rich. Enjoy a wide variety of online gambling as well. Many online gambling games are available to give players the opportunity to gamble. No matter what kind of game you do not miss the fun, because we have gathered all online games betting for you to share the service. Many of the joys of online games make rich players. It also challenges all user experience. Online casino games that are exciting games. The gambler will continue to provide the service at any time the bettor wants. If you want to bet on online casino games and do not want to miss out on new online games, you can risk clicking. รูบี้888

    ReplyDelete

Back to Top